Diesel Place banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hoping for some quick help on this. Our 2002 Duramax is throwing P0202. I see on the LLY Duramax this is an easy fix. I cannot find any detail on fixing this on the LB7.

Is there a fix as easy as on the LLY?

If so, where do I find the correct wiring harness for injector 2?
Appreciate any guidance!
 

·
Administrator
Joined
·
17,213 Posts
Welcome to DieselPlace
Are you only getting the P0202 code with this issue or are others appearing?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Only the one code. Today it would not start either. I primed several times and it did eventually start. Drove for a bit and it was actually going into limp mode - this is the first it actually limped since throwing the code. When I pulled into the drive way it ultimately stalled.

Thinking there is more than the P0202 going on even though that is the only code.
 

·
Administrator
Joined
·
17,213 Posts
Only the one code. Today it would not start either. I primed several times and it did eventually start. Drove for a bit and it was actually going into limp mode - this is the first it actually limped since throwing the code. When I pulled into the drive way it ultimately stalled.

Thinking there is more than the P0202 going on even though that is the only code.
Only the one code. Today it would not start either. I primed several times and it did eventually start. Drove for a bit and it was actually going into limp mode - this is the first it actually limped since throwing the code. When I pulled into the drive way it ultimately stalled.

Thinking there is more than the P0202 going on even though that is the only code.
I would replace or repair the pigtail connector and see if things improves
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
That’s where I run into an issue - I can’t locate the pigtail to be replaced. I don’t see a connector where the videos of the LLY indicate it is. It seems rather easy to locate on the LLY, I just don’t see the pigtail in the same location on the LB7
 

·
Administrator
Joined
·
17,213 Posts
That’s where I run into an issue - I can’t locate the pigtail to be replaced. I don’t see a connector where the videos of the LLY indicate it is. It seems rather easy to locate on the LLY, I just don’t see the pigtail in the same location on the LB7
The LB7, you have to remove the valve cover to expose the Injectors
 
1 - 7 of 7 Posts
Top