Diesel Place banner

1 - 20 of 24 Posts

·
Registered
Joined
·
178 Posts
Discussion Starter #1
I'm having trouble trying to figure out where this code could be coming from. I'm not running a blocker plate and my kitty is still on. I am running the edge with a boost stick. Anybody have any ideas??
 

·
Registered
Joined
·
2,012 Posts
Do you have a stock air intake assembly?...How many miles on the truck?
 

·
Registered
Joined
·
2,194 Posts
This code is a maf sensor code, are you running a aftermarket intake? This will turn on that code, nothing to woory about, though.
 

·
Registered
Joined
·
178 Posts
Discussion Starter #4
I have the 06 lbz intake and the maf has been recalibrated with the reflash that goes along with the conversion. I have about 35k on the truck. The truck has a noticable loss of power in the lower rpm range or until it builds boost.
 

·
Registered
Joined
·
2,012 Posts
Dirty MAF sensor?????
 

·
Registered
Joined
·
2,012 Posts
bsanders;1413805; said:
I will clean it in the morning and see what happens.
Use electric parts cleaner and BE CAREFUL...The element is fragile...
 

·
Registered
Joined
·
108 Posts
p0101

Bsanders -
I have the same issue but the only thing we have in common is the boost stic. I have the blocker installed w/fingerstick and I have stock intake and air box. I cleaned mine yesterday and will look in a couple of days to see if it's back. I'm also back to the stock tune. I've done the cleaning before. - Mark
 

·
Registered
Joined
·
1,303 Posts
med8921;1414139; said:
Bsanders -
I have the same issue but the only thing we have in common is the boost stic. I have the blocker installed w/fingerstick and I have stock intake and air box. I cleaned mine yesterday and will look in a couple of days to see if it's back. I'm also back to the stock tune. I've done the cleaning before. - Mark
As you can see from my sig, I have the stock airbox with the blocker plate and the boost stick, with a Predator. I have seen MAF codes in the past as well. I have cleared them, but they keep coming back. I have also cleaned the MAF, but it made no difference. I have seen no effect on performance or mileage, so I have not worried about it too much. If someone has a solution to preventing these codes, I would like to know as well.
 

·
Registered
Joined
·
4,148 Posts
Tutts;1414347; said:
As you can see from my sig, I have the stock airbox with the blocker plate and the boost stick, with a Predator. I have seen MAF codes in the past as well. I have cleared them, but they keep coming back. I have also cleaned the MAF, but it made no difference. I have seen no effect on performance or mileage, so I have not worried about it too much. If someone has a solution to preventing these codes, I would like to know as well.
Finger stick might help.
 

·
Registered
Joined
·
178 Posts
Discussion Starter #11
I cleaned it and it still through the code. I can clear the code and as soon as I start the truck it comes right back. I dropped it off at the dealer and we will see what they find. It will throw the code completely stock.
 

·
Registered
Joined
·
378 Posts
I have the same problem. I get the code and engine service light comes on. At first I was clearing the code and the light would go off now, if I don't clear the code the light goes off after few starts. I have not notice any change in power or MPG. I have bloker plate and FS. I also use predator at level II. The engine serice light drive me crazy thoug. I have less that 10 K on odo with stock air box. I have cleaned MAF with no result.
 

·
Registered
Joined
·
378 Posts
No more ideas on this thread?
 

·
Registered
Joined
·
837 Posts
I know that people with tuners and box's don't want to here this but in some tunes that you buy the tuners failed to fix the maf expected air flow tables. Gran-it there is allot of room for error built in the ecm if you are moving more or less air than what the ecm is programmed to see you will get some codes if it goes beyond those tables. Don't quote me on this but I think it is the P0101 that I was getting also when I was running a Bully Dog tuner, I always thought that the MAF was getting oiled from my airaid intake or it was just bad, but when the tune was removed the code was gone every time. I'm not making a sales pitch here but when I bought my EFI live I logged the air flow tables for the Bully Dog tune and it was exceeding what the ecm was programmed to see plus the built in error. I was also running a banks big head that actually allowed the turbo to build more boost from 22 psi to 30-32 psi so it is to blame for more airflow also. I could even duplicate the same problem when I built my own tunes and not rescaling the MAF tables, after they were fixed the code was gone.
 

·
Registered
Joined
·
178 Posts
Discussion Starter #15
They replaced the maff sensor and it still throws the same code. It will be going back to the stealer.
 

·
Registered
Joined
·
543 Posts
rcr1978;1419805; said:
I know that people with tuners and box's don't want to here this but in some tunes that you buy the tuners failed to fix the maf expected air flow tables. Gran-it there is allot of room for error built in the ecm if you are moving more or less air than what the ecm is programmed to see you will get some codes if it goes beyond those tables. Don't quote me on this but I think it is the P0101 that I was getting also when I was running a Bully Dog tuner, I always thought that the MAF was getting oiled from my airaid intake or it was just bad, but when the tune was removed the code was gone every time. I'm not making a sales pitch here but when I bought my EFI live I logged the air flow tables for the Bully Dog tune and it was exceeding what the ecm was programmed to see plus the built in error. I was also running a banks big head that actually allowed the turbo to build more boost from 22 psi to 30-32 psi so it is to blame for more airflow also. I could even duplicate the same problem when I built my own tunes and not rescaling the MAF tables, after they were fixed the code was gone.
Yeah, I think you nailed it. I'm pretty sure that mine is caused from the Predetor.
 

·
Registered
Joined
·
618 Posts
Threw a p0101 tonight too, mine must be my airraid though. Just cleaned and oiled it a day or so ago, has never gone off before. I did install my blocker plate then too, (finger stick already on there for exhaust codes). I am just gonna clean the MAF and see what that does..
 
1 - 20 of 24 Posts
Top