Diesel Place banner

21 - 24 of 24 Posts

·
Administrator
Joined
·
16,342 Posts
7/18/20. 1 battery was 4.2v when second battery wasnt hooked up. agm batteries die different than other batteries and not in a good way. I wonder if that would affect the electronics of the truck? starts happier, will see if it operates better now. I know when they both go bad truck goes crazy and shuts down.
Batteries should be replaced as a matched set and both be hooked up
 

·
Registered
Joined
·
2,579 Posts
All vehicles always run the best with fully charged battery(ies). Electronics always like 12.6 or better, although they will often do OK with a little less. When your truck battery is less than fully charged, your alternator (assuming it is working correctly) is continually attempting to charge your batteries, get them up to full charge. You are paying extra in fuel costs to keep that alternator pumping out those amps.
 

·
Registered
2007 classic gmc cc
Joined
·
38 Posts
Discussion Starter #23
got 1 new warrantee battery. starts better. had other battery replaced about 9 months ago, warranted. new 1/2019.
.
 

·
Registered
2007 classic gmc cc
Joined
·
38 Posts
Discussion Starter #24
replaced filter 6/19
3.0 vac. 2.5 pressure running. 3.2 pressure not running.
changed filter 7/31/20
same numbers.
towed 170 miles twice.
in drive, cruse on, 80f degrees.
set code 87 twice first trip.
so it a lot better than it was, but it still happens. checking pressures on my scanner show they are much better than they were. goes over 20,,000 to 26,000+ no problem.
I have the Kennedy single pump kit. ordered the second pump today. ordered kennedy mega filter also, will install that after some test tows with second pump and pressure readings.
cp3 pump pressure on tow up from florida to Michigan almost never went over 20,000 , 17-18,000 lots of 87, restrict to 5th, manual to 4th or 3rd. no cruse.
hope trip back home is smoother.
 
21 - 24 of 24 Posts
Top