Diesel Place banner

1 - 5 of 5 Posts

·
Registered
Joined
·
72 Posts
Discussion Starter #1
After plugging everything up I can't find the plug that plugs into the oil pressure sensor. There is a plug that is yellow on the inside behind the ac compressor but it's off the Fuel Injection Control Harness. I've been told the oil pressure sensor plugs into the engine harness and I been told there is a harness that plugs into this Fuel Injection Harness. There is not a plug on the engine harness for the OPS. My truck is an 04 LB7 and I can't find anything on alldata.

Thanks for your help.
 

·
Registered
Joined
·
18 Posts
on my 02 the ops wires come from beside-to slightly under the drivers side of the turbo then down drvers side of engine to the ops. I just had to replace my ops. I put the truck on a lift, droped the front diff. then got the to ops. You could get to it from the drivers wheel well cover. While on the lift I looked to see how easy to get from the wheel well. Droping the diff was less aggravating.
 

·
Registered
Joined
·
173 Posts
My truck is at the dealer for warranty work, so I can't look at it to see, but I did look at the service manual. It shows 3 wires to EOP sensor: black, tan/white, & gray. They come off a 38 pin connector "C107" which is described as: Main engine harness to engine jumper harness, mounted to top of driver side valve cover. From this, I assume you should be looking for the engine jumper harness and the 3 wire colors to trace down the EOP plug. Don't know if this helps, but maybe somebody else can be more specific.
 

·
Registered
Joined
·
72 Posts
Discussion Starter #4
I've looked all over the harness for the connectors but it's just not there. Can someone that has an 04 look to see where/what harness plugs into the ops? I hope I don't have the wrong harness. The dealer guy says the 1 codes are different from the 2 codes.

Thanks for the help.
 

·
Registered
Joined
·
173 Posts
The manual is very confusing and seems to be missing some info in this area, but from what I can tell, there should be a 5 wire Engine Jumper Harness. The harness serves the oil level sensor and EOP (engine oil pressure) sensor. The harness plugs into your main engine harness at the C113 plug (black plug with 6 pins). Maybe you need this engine jumper harness?? Do you have the oil level sensor plug. It should be on the same harness. Again, manual is confusing, so I am not sure if this is correct, but look to see if you have a 6 pin (black) plug that is unused.
 
1 - 5 of 5 Posts
Top