Diesel Place banner

1 - 10 of 10 Posts

·
Registered
Joined
·
1,714 Posts
Discussion Starter #1
My radio didnt work on the way home today. Dead, nothing, nada, zilch, ZIPPO!


Got home, checked all the fuses. They were fine. Reinstalled the same fuses.


Turned the ignition back on and the radio worked fine. Now Im really nervous about "intermittent" problems.
 

·
Registered
Joined
·
3,410 Posts
Early on my cruise cntrol did that a few times early on, once I had maybe 8,000 miles on the truck it has never done it again.


Life is short, worry about more important things.
 

·
Registered
Joined
·
1,146 Posts
I have/had the same thing happen three times in the last month. went away when I used the other set of keys or simply from a shutdown and subsequent restart. if it continues, i will take it in..........
 

·
Registered
Joined
·
294 Posts
I agree with ski 1's suggestion. Some keys do not more the operating rod far enough to ingage all blocks in the ignition switch equealy. If this happens again try wiggling the key while the truck is running. If the radio comes on after this test I would change keys.
 

·
Registered
Joined
·
812 Posts
Same thing happened when truck was new, has gone away now. Just past 20k today...For about four weeks now my rear doors don't want to lock all the time. Has been to the shop three times. Were down to only one door that can't follow the rules. Shop manager confused, has replaced all the parts and tested all of the wires. Has seen it do its thing and still can't believe it.
 

·
Registered
Joined
·
1,242 Posts
Happened to me on my 2003 the first day I had it. I took the radio fuse out and reinstalled. Works great for the last 12ooomiles.
 

·
Banned
Joined
·
6,539 Posts
I hardly use my radio anymore. Sounds like sh*t.
 

·
Registered
Joined
·
1,242 Posts
Try playin some rock n roll...radio might sound better!


 
1 - 10 of 10 Posts
Top