Diesel Place banner

1 - 20 of 22 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
I AM HAVING FITS WITH MY WASTEGATE SOLINOID. THE ONLY CODES I HAVE ARE 78 WASTE GATE FAULT. I HAVE A 'NEW' SOLINOID,LIFT PUMP AND OPS. PUT ON TODAY. I HAVE STRONG VAC TO SOLINOID BUT SOLINOID WILL NOT SEND VAC TO WASTEGATE,SO ITS THROWING THE 78 FOR LOW BOOST. RUN VAC STRAIGHT TO WASTEGATE AND ITS GOT POWER LIKE NEVER BEFORE BUT IS THROWING 78 FOR OVER BOOST.BUT HERES THE KICKER IT IS THROWING THE 78 AND GOING INTO LIMP MODE AT EXACTLY 70 MPH
!!NO MATTER HOW YOU GET THERE IE. FLAT ON THE FLOOR OR SOFT PEDEL. I HAVE CHECKED ALL MY WIREING ETC. WHAT CAN I CHECK NEXT?? PLEASE HELP
!! SOMEONE THROW ME A BONE HERE
 

·
Registered
Joined
·
18 Posts
Discussion Starter #3
THANKS GMCSID I THINK THIS WILL HELP OUT!!
LOOKS LIKE THE DIAGRAM IS FOR THE L56 EGR ENGINE WITH THE 3 SOLENOIDS. MINE IS THE L65 NON EGR HD ENGINE WITH ONLY THE WASTEGATE SOLENOID BUT IT LOOKS LIKE THE SAME LAYOUT OVER ALL..
 

·
Registered
Joined
·
18 Posts
Discussion Starter #4
I HAVE CONCLUDED THAT THE YELLOW WIRE FROM ECM TO THE SOLENOID IS MY PROBLEM. AS THE ECM CONTROLS THE GROUND AT THE SOLENOID TO REGULATE VAC TO THE WASTEGATE THRU THE SOLENOID.WITH THAT BEING SAID, DOES ANYONE KNOW OR HAVE A DIAGRAM THAT SHOWS EXACTLY WHICH YELLOW WIRE IS THE WASTEGATE GROUND WIRE ON THE ECM?? I BELIEVE ITS GOING TO BE ON THE 24- PIN CONNECTOR IN THE MIDDLE BETWEEN THE TWO 32-PIN CONNECTORS..I FEEL I WILL BE BETTER OFF RUNNING A FRESH GROUND WIRE FROM THE ECM TO THE SOLENOID RATHER THAN DIGGING INTO THE RAT NEST OF WIRES IN THE ENGINE COMPARTMENT, AS TO RISK BREAKING ANY OTHER WIRES IN THE PROCESS..
THE ONLY OTHER POSSIBILITY THAT COMES TO MIND IS A FAULTY ECM.
LETS HOPE NOT. I WOULD RATHER TRY THE NEW WIRE REROUTE INSTEAD..
ANY HELP HERE WILL BE GREATLY APPRECIATED...
 

·
Registered
Joined
·
18 Posts
Discussion Starter #6
WELL I JUMPED A3. STRAIGHT LINE TO THE NOID. STILL NO DICE. TOOK HER FOR A SPIN STILL THRU "78" ONLY. WHAT NEXT??
WHAT TELLS THE ECM TO SEND THE SIGNAL? IS ECM AT FAULT?? MAP? BARO?
THANKS FOR ALL THE HELP SO FAR!! WELL GET IT SOONER OR LATER!!
 

·
Registered
Joined
·
1,240 Posts
I would check for power at the A terminal with key on at the solenoid with a test light (very important to use test light not meter). Then check resistance of the other circuit from the PCM to the solenoid w/key off, should be less than .2 ohm. If both those are good the problem is in the PCM or the inputs the PCM uses to control boost pressure. I would get a Tech 1 or 2 to see if the MAP and BARO are reading correctly before replacing the PCM.
 

·
Registered
Joined
·
584 Posts
My truck was not throwing codes but had no vacum to the waste gate becasue the phoney little vacum lines started to leak. I put on a Heath Turbo Master $63 bucks and TAAADAAA boost and no more worries about vacum.
 

·
Registered
Joined
·
294 Posts
16gaSaS


You beat me to it. As I read down through the thread I intended to say replace it with one of Bill's Turbo Master and get more boost and far less headaches.
 

·
Registered
Joined
·
1 Posts
So... if you have the "Heath turbo master" you don't need vacuum to operate the wastegate? I am new to the group.... have had a '94 3500 for about 7 years.... lately my turbo isn't boosting... I have no power, can't hear the turbo wind up at all, black smoke at heavy throttle.... was thinking about some type of manual controller.... saw an electronic module that connects into the stock wiring that allowed you to dial in whatever boost you wanted... can't find the thing now. Any advice to get my boost back?


Thanx
 

·
Registered
Joined
·
18 Posts
Discussion Starter #11
yes the turbo master is spring loaded to close wastegate.spring is adjustable to raise or lower boost. but what i understand you still need to add the eletronic boost controler (fooler) to alow for the raised boost levels. because the computer will still throw a code for overboost without it. i am going to add both products together so i can run around 10 psi of boost. the computer wont let it run that high without a fooler..
 

·
Registered
Joined
·
584 Posts
GREEN95CHEVY said:
yes the turbo master is spring loaded to close wastegate.spring is adjustable to raise or lower boost. but what i understand you still need to add the eletronic boost controler (fooler) to alow for the raised boost levels. because the computer will still throw a code for overboost without it. i am going to add both products together so i can run around 10 psi of boost. the computer wont let it run that high without a fooler..

Green:


I would suggest rather than getting the Boost fooler get Heaths MaxETork chip and the Turbo Master, I think he sells the pair for like $319. I have both and they work SWEET together Bill suggest you run about 13 PSI with his Chip and I have power and fuel right to 3500rpm and changes shift points on the transmission plus NO MORE speed limiter (other than you guts and brain),
 

·
Registered
Joined
·
5,245 Posts
Well here's my two cents,


First of all, my stock pcm,stock turbo,vac set-up and all '94 L65 makes 16 psi boost and only throws code 78 when there's a leak in the system. The stock set-up uses the vac to close the turbo, not open it. I can't see buying a mechanical spring to replace a computer controlled part that should be adjusted through pcm reprogramming if anything. My plans for this truck are to divorce the exhaust and run twin turbos. I intend to use the stock vac set-up with the addition of a T and a second line to the new driverside turbo. This will allow the PCM to controll both turbos in unison. My goal is to reduce back pressure at the turbo(s), not to mention the advantage of Having 2 downpipes.





jofox10,


Sounds like the wastegate solenoid.Edited by: quantum mechanic
 

·
Registered
Joined
·
5,245 Posts
Also if you have the vac lines backwards it will let vac leak past the solenoid.
 

·
Vendor
Joined
·
9,676 Posts
Check the ground wire from solenoid is not open. If it isn't, then I'd try a PCM. The PCM grounds the circuit to pulse the solenoid.





I did not quite follow how you came to your conclusion. Are you lacking 5v signal to solenoid or ground signal?


BTW, in a fully functional system, a properly set up chip will not need a wastegate mod, it will control it properly by itself...


Edited by: Kennedy
 

·
Registered
Joined
·
18 Posts
Discussion Starter #16
ITS MISSING THE GROUND SIGNAL..WIRING IS GOOD FROM A3 TO THE NOID.
 

·
Registered
Joined
·
7,432 Posts
I think your wastegate solenoid if faulty.
 

·
Vendor
Joined
·
9,676 Posts
Time for a PCM...
 

·
Registered
Joined
·
1 Posts
I have the exact same problem, and did all the things you did. The solenoid works when connected to other ground source, and the yellow wire to A3 is OK. All MAP/BARO/Temp sensors plus all solenoids changed...


My guess is also PCM, but I´ll go for a spring instead. Cheaper and at least roughly the same result.


/JS


1995 K2500
 

·
Registered
Joined
·
584 Posts
Kennedy said:
BTW, in a fully functional system, a properly set up chip will not need a wastegate mod, it will control it properly by itself...

Yupp John your right, but why futz keeping the Vacum system going when a manul waste gate controller eliminates the need for it. That just my thinking.
 
1 - 20 of 22 Posts
Top