Diesel Place banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Hello and Happy New year,

-2006 ccsb 4x4, LBZ/ally 6 speed, turbo wheel upgrade, 8"lift, intake. Everything else stock. 186k miles.


I bought the truck 2 years ago as is from an auction as it was sold by the insurance co. Due to the truck being stolen. The truck runs excellent, shifts perfect etc. The manual shift mode has never worked since I've owned the truck, when you switch to manual mode the DIC just shows the truck in 6th gear although it just shifts normal as it would be in drive mode. Tow/haul button and feature works perfect.
So I've put off fixing it until this week. I tore down the steering column and wouldn't you know it! I found broken wires from the tilt function of the steering wheel...I fixed the wires going if you the shift lever but no change, manual still won't work. Tow/haul mode still works. So I also have a 2007 classic LBZ w/t with the same shifter and manual tap shift function..,.so I swapped the 07 lever into the 06, No change. Then I swapped the lever out of the 06 into the 07 and that tap shift worked perfect. So it's not the tap shift lever...is it the TCM? I checked all fuses, everything is fine . I really don't want to throw a new tcm in if that's not it. Any help and suggestions is GREATLY appreciated. Thanks all
 

·
Administrator
Joined
·
17,650 Posts
Welcome,
I moved your thread over to the "Electrical" section of the forum for more appropriate responses to your issue

:thumb:
 

·
Registered
Joined
·
2 Posts
I have no Codes coming up. I scanned with my PPE scanner and my gm diablo sport. That's what's weird. I had a glow plug code for a bad glow plug (#3) but nothing pertaining to the tap shift or tcm. I'm presuming the tap shift communicates directly with the tcm? Is there any other location it goes through that I should check. Thanks
 

·
Registered
Joined
·
2,689 Posts
Get a wiring diagram and see what is on the same circuit as the shifter you are having problems with. I PRESUME that the new shifter you installed is functional, but that is not the complete circuit - so check the complete circuit.
 
1 - 5 of 5 Posts
Top