Diesel Place banner

1 - 15 of 15 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
I have a 2003 Silverado with a 6.6 Duramax. I am having a no start problem.
It will start and run fine if it is pushed off, but will not start when cranked. It is cranking good.

Thanks
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
It is a manual tranny, so if I coast it down the hill and pop the clutch it will start. Also will start if I use a little starting fluid.
 

·
Registered
Joined
·
3,291 Posts
I have a 2003 Silverado with a 6.6 Duramax. I am having a no start problem.
It will start and run fine if it is pushed off, but will not start when cranked. It is cranking good.

Thanks
Are you sure it is "cranking good"?

I've heard the D-Max needs a starter cranking speed of 100 RPM to start. You have an "03". Do you have original batteries? Poor batteries = slow cranking speed. You might want to load check the batteries independantly.

Others here thought they had good cranking, but had degraded batteries. Many people seem to need new batteries after 3-4 years.
 

·
Registered
Joined
·
514 Posts
I have a 2003 Silverado with a 6.6 Duramax. I am having a no start problem.
It will start and run fine if it is pushed off, but will not start when cranked. It is cranking good.

Thanks
Do you have an Edge Juice Box? There have been issues with the ver 4.81. for LB7 I personally had no start issues with it. Replaced it and no problems..Don't see your Sig..Oh by the way Welcome to place...
 

·
Registered
Joined
·
27 Posts
no time too........

It does help a bunch if you take time to post a signature. Saves alot of questions. Could be the juice if you have one. They do cause alot of no start issues.:help2:
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #8 ·
It is stock. No add ons. I have a feeling the injectors are not pulsing at startup, trying to look in to that now.
 

·
Registered
Joined
·
27 Posts
Does this happen engine cold or hot or both? Fuel filter changed recently? Might have injector problems. Do you have a tool to read injector balance?
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #10 ·
Is doesn't matter hot or cold. New filter, second one. Yes I have a tech 2. Cyl balance test looks good.
 

·
Registered
Joined
·
27 Posts
Are you getting a ses light? any codes? Sometimes you can get air in fuel filter. Did you just change filter? Next time it doesn't start with starter motor try to pump up the plunger on top of the filter head till it gets hard to push then try to start.
 

·
Registered
Joined
·
939 Posts
You mentioned you had a tech 2. Check your fuel rail pressure. Could be an injector returning too much fuel back to the tank??
 

·
Registered
Joined
·
27 Posts
How low is your fuel level. Might be picking up fuel when going down hill bump starting and on level ground the fuel pickup is not covered with fuel.
 

·
Registered
Joined
·
3,291 Posts
Why would a filter or injector issue, not be an issue when push starting? Is this affected by RPM?
I was wondering if one of two, of the six switches on the Ignition Switch is defective in the "Start" position.
One of these supplies +12V to fuses IGN 1 Fuse 10A, when Ign Switch is in Start or Run. Check the supply side of this fuse when Ing Switch is in "Start". Should be +12V.
The second one supplies +12V to IGN 0 Fuse 10A also in Start and Run. Check the supply side of this fuse when Ing Switch is in "Start". Should be +12V.
Again, both of these fuses should have +12V when in Start and Run. These fuses should be good, because your truck works in the Run position.
Reference 2002 Helms, page 8-42 and 4-43.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #15 ·
Fuel rail pressure is 800psi when cranking. Fuel is 3/4 tank. Ignition 1 is good in run or crank. I am going to try and shut off the return to see if that raises the pressure. I am getting a code for fuel pressure sensor, but the sensor checks good.
 
1 - 15 of 15 Posts
Top