Diesel Place banner

1 - 8 of 8 Posts

·
Registered
Joined
·
71 Posts
Discussion Starter #1
I have an 05 4x4 crew cab. Recently i started having no power steering at idle. It was'nt to bad at first, but yesterday I had to take it to the dealer. I am running 285's, and they thought that might be the problem. Anyone ever had this problem? The dealership is super nice and agreed to replace the pump and possibly the steering box also. Even though they mentioned the 285's, they said they will replace the pump as many times as they have to, to fix the problem. Just wondering if anyone else has had the related problems. Thanks.
 

·
Registered
Joined
·
140 Posts
Sounds like something else is wrong, the 285's should not have anything to do with loosing the power steering.
 

·
Registered
Joined
·
1,262 Posts
John...I'm runnin 315's on an '02 and don't have a problem.

My $.02 worth.

MaxRock
 

·
Registered
Joined
·
1,371 Posts
Mine does it too, I wonder if it isn't the recall they have for the '05 power steering...
 

·
Registered
Joined
·
1,238 Posts
probably the power steering pump shaft. they were bad in earlier trucks, don't know if they are improved or not.
 

·
Registered
Joined
·
1,460 Posts
285 should not be a problem it is more than likely just the pump
 

·
Registered
Joined
·
9 Posts
Ihave had the pump changed twice now. It helps for a bit and always seems to come back worse. Wife quit driving the truck cause she can't muscle it into parking spots, assist just quits. Dealer has no idea other than "GM is aware of the problem but does not have a fix" What is the steering recall all about? This is the first I have heard of it. Maybe it is something I can pass along to the dealer.
 
1 - 8 of 8 Posts
Top