Diesel Place banner

1 - 19 of 19 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
I changed my thermostats. I had a CEL and an error code(on torque app).
I removed radiator shroud, removed air resonator, unplugged A/C and moved compressor.
Afterwards, I have a CEL light with no error codes.
I clear "absent" code and start truck directly, no pause for glowplugs and it starts with no CEL light.
If I pause for glowpugs, the indicator stays on for 45 seconds. And I get a CEL.
I believe that I am running with no glowplugs.
I checked all connectors. That's as far as I have gotten. Be Sunday before I can look at it again.
 

·
Premium Member
Joined
·
775 Posts
Check the wires at the glow plug module. Up against the firewall Ivo the steering shaft. When I replaced my injectors on the LB7 they got reversed. Two identical black wires, same symptoms. Not sure if it applies on an LBZ, but worth a look.

Sent from my Pixel 3 XL using Tapatalk
 

·
Registered
Joined
·
21 Posts
Discussion Starter #3
Works fine when it is warm.

The glowplug light comes on and turns off immediately because engine is warm. Truck starts and runs normally with no CEL or fault code.
I did start truck cold and received a p0116 fault code, for ECT temperature. Which was original code where I was advised to change thermostats.
Before that, I was getting glowplug light on for 45 seconds, A CEL but no fault code(using torque pro, an app).
 

·
Registered
Joined
·
21 Posts
Discussion Starter #4
Check the wires at the glow plug module. Up against the firewall Ivo the steering shaft. When I replaced my injectors on the LB7 they got reversed. Two identical black wires, same symptoms. Not sure if it applies on an LBZ, but worth a look.

Sent from my Pixel 3 XL using Tapatalk



The glowplug module on my firewall has two different connectors. I disconnected some smaller connectors, ECT sensor, A/C in thermostat area when I was working there but I can't see any that I missed reconnecting. I was looking for a glowplug relay as LB7 has but LBZ doesn't seem to have one.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #5
Has anyone ever had multiple glowplugs out with no glowplug fault?
I am using a dmm on this now and I have more than 1 glowplug at 1 megohm or higher.
Still have 3v to glowplug when key is turned on.
 

·
Premium Member
Joined
·
775 Posts

·
Premium Member
Joined
·
775 Posts
Appreciate the info. I would have to check on emissions. truck is in Mass.

I will doublecheck the electrical connections though.
Yeah, I think the point is that one has a bus bar on them and one doesn't. More importantly, if you do decide to change the glow plugs at some point, the old GM software caused the tips to swell and the update fixed that. IIRC, many a swollen tip have broken off in the cylinder during removal. Bad, bad bad. Might be worth having a shop do it. All this for a thermostat change. What a PITA. Sorry man.

I've also read that a TECH II can read individual voltages, fwiw.

Also, the Roswell is a pilot, not a mechanic. So there's that.

Sent from my Pixel 3 XL using Tapatalk
 

·
Registered
Joined
·
21 Posts
Discussion Starter #9
Yeah, I think the point is that one has a bus bar on them and one doesn't. More importantly, if you do decide to change the glow plugs at some point, the old GM software caused the tips to swell and the update fixed that. IIRC, many a swollen tip have broken off in the cylinder during removal. Bad, bad bad. Might be worth having a shop do it. All this for a thermostat change. What a PITA. Sorry man.

I've also read that a TECH II can read individual voltages, fwiw.

Also, the Roswell is a pilot, not a mechanic. So there's that.

Sent from my Pixel 3 XL using Tapatalk



Pilot of what?
 

·
Premium Member
Joined
·
775 Posts
Everything from a 737 to a Bell 204. I'm rated to fly and instruct in everything the FAA has ratings for except float planes, tail draggers, and gliders. I have aircraft systems bouncing around in my head that would make normal people... Fall sleep. Sometimes it helps with the trucks. High pressure fuel systems, bypass filtration, cooling, etc. It's all pretty much the same fundamentally. How GM bastardized it is the trick. *shrug*

Sent from my Pixel 3 XL using Tapatalk
 
  • Like
Reactions: Saltfever

·
Registered
Joined
·
2,513 Posts
Has anyone ever had multiple glowplugs out with no glowplug fault?
I am using a dmm on this now and I have more than 1 glowplug at 1 megohm or higher.
Still have 3v to glowplug when key is turned on.
Your voltage is a little low. Should be about 4.05V
When ever I had a bad glow plug I hade a CEL light on and glow plug worm wouldn’t go out until started.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #12
Everything from a 737 to a Bell 204. I'm rated to fly and instruct in everything the FAA has ratings for except float planes, tail draggers, and gliders. I have aircraft systems bouncing around in my head that would make normal people... Fall sleep. Sometimes it helps with the trucks. High pressure fuel systems, bypass filtration, cooling, etc. It's all pretty much the same fundamentally. How GM bastardized it is the trick. *shrug*

Sent from my Pixel 3 XL using Tapatalk



That's cool.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #13
Is there a trick to pulling square connector on an LBZ glowplug control module?? All other connectors have locking cam levers.
 

·
Registered
Joined
·
2,513 Posts
It has a slide lock underneath where the wires come from on the plug. Slid it out while wiggling the connector.
There’s also YouTube videos if you like watching.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #15
It has a slide lock underneath where the wires come from on the plug. Slid it out while wiggling the connector.
There’s also YouTube videos if you like watching.

Thank you. I found it yesterday. There's a grip piece under cable and it slides back like a drawer. Pretty elaborate.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #16
I replaced my gpcm about 2 months ago. I haven't been driving my truck for 2 months due to this virus thing.
So, I checked codes yesterday and had a p0160c code for gpcm and ecm program not matching.
It's warm out. I don't need glowplugs.
I want to tow 4k lbs about 1500 miles roundtrip.
I am thinking of putting old gpcm back in to clear fault, then change it when I get back.
Does that sound advisable?
 

·
Premium Member
Joined
·
775 Posts
Did you try starting it like a gasser after you clear the codes? IIRC, if you don't allow the gpcm to time out, it won't set the codes. I think...

Sent from my Pixel 3 XL using Tapatalk
 

·
Registered
Joined
·
21 Posts
Discussion Starter #18
Exactly, It's warm. I cleared code. I started it right up, and no codes.
I appreciate the help.
When I get back, I will find someone with tech II or buy a single vin EFILive.
 

·
Premium Member
Joined
·
775 Posts
I'm glad it worked!

Sent from my Pixel 3 XL using Tapatalk
 
1 - 19 of 19 Posts
Top