Diesel Place banner

Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Ok here it goes, i had the cat removed and now my check engine light comes on. I have the fingerstick on there but the check engine light still comes on, it looks to be installed right! I had some one scan it but they just deleted the code but had said something about the maf sensor. My truck doesnt run good. Its a 05 C.A truck i understand about the C.A law but people have said that they have no problem with there truck. if anyone has some advise on how to fix this beside to put the cat back on that would help out alot. It sounds to clean with out the cat i dont want it back on.
 

·
Registered
Joined
·
722 Posts
i think you may have to also put on the EGR blocker plate from what i have read in past threds
 

·
Registered
Joined
·
1,457 Posts
try cleaning your MAF sensor and see if it still does it. Having a signature about your truck would help out more.
 

·
Registered
Joined
·
41 Posts
Customer of mine is having the same problem.

I put the finger stick on, and it is installed properly, but he still gets the CEL, but only rescently. It worked fine for about 6-8 months now. He does not have a block plate, but is running a K&N drop in filter.


Anybody have any clues? Dirty MAF, and a block off plate? That WILL, or SHOULD fix the problem?


Merrick
 

·
Registered
Joined
·
1,922 Posts
Install finger stick and make shure you soder the connection.
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top