Diesel Place banner
1 - 10 of 10 Posts

·
Registered
Joined
·
320 Posts
Discussion Starter · #1 ·
Just got the new engine in and bolted up, put the key in and turn it over......... Just cranks away. My gut feeling is it has to do with the injectors. Maybe not spraying fuel, or maybe just not getting the signal from the ecm to spray. Does anyone have ideas about what it could be? or maybe someone knows the color of the wire that carries the voltage to the injectors. So as i could back probe to check for signal. Also, I did throw a p0090. (ecm related, fuel pressure reg control curcuit) Thanks!
 

·
Bac To The Future
Joined
·
23,008 Posts
First thing I'd check is if the fuel system lost prime, and if so, clear the air out at the filter head.
 

·
Registered
Joined
·
320 Posts
Discussion Starter · #3 ·
Ok, i found that the FICM pulses the neg to injectors thorugh the Lt green wires on the harness. It looks like Batt pos is there to the injectors when key is turned on. How much voltage should i see to the injectors during cranking?
 

·
Registered
Joined
·
320 Posts
Discussion Starter · #4 ·
We pumped the prime pump till fuel got to the filter, then cranked and bled at the filter bleed screw till no more air was present.
 

·
Registered
Joined
·
594 Posts
QUAD;1600938; said:
We pumped the prime pump till fuel got to the filter, then cranked and bled at the filter bleed screw till no more air was present.
After it bleeds from the bleed screw, close the screw and continue to pump until you feel a lot of resistance.:thumb: Now you're gettin' it in there.
 

·
Registered
Joined
·
320 Posts
Discussion Starter · #7 ·
Does anyone know of a bleeding point to bleed the common rails besides at each injector line from the common rail?
 

·
Registered
Joined
·
70 Posts
ericjs;1600991; said:
after it bleeds from the bleed screw, close the screw and continue to pump until you feel a lot of resistance.:thumb: now you're gettin' it in there.
x2
 

·
Registered
Joined
·
173 Posts
When you put in the new engine, did you replace the PCM? If you did, the PCM has to learn the fuel continue/enable command from your BCM (part of the passlock security system). Truck will crank, but not start. There is a 30 minute learn procedure that can be done without any scanners or tools. I know it is on the forum (I think in FAQ), but if you can't find it, let me know and I will PM the procedure to you.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top