Diesel Place banner
1 - 10 of 10 Posts

·
Registered
Joined
·
349 Posts
Discussion Starter · #1 ·
96 Ford L8000 With Cummins and a Eaton Fuller 8 speed. I think it is the 5.9L. I have already replaced the lift pump and got it from Ford, brand new pump. The problem is that when your in 8th gear the motor dies, but if you hold the fuel to the floor the motor it will start up at aroud 45 mph. It also has a new fuel filter. Any help would be great at this point.

Thanks Mike

BTW 58000 GVW Twin Screws
96 National 900 23 Ton Boom Truck
 

·
Registered
Joined
·
349 Posts
Discussion Starter · #4 ·
No, I have not. Where would it be located, or what do they kinda look like?
Thanks,
Mike
 

·
Registered
Joined
·
241 Posts
would you be willing to sell this unit if its fixed?
 

·
Registered
Joined
·
241 Posts
also-sounds like it is starving for fuel under load. i think this usually is a pump problem but youve replaced it already. maybe injector pump?
 

·
Registered
Joined
·
7,134 Posts
The shutoff solonoid is the solonoid on the side of the injection pump. Take a bujee strap and use it to pull the arm up and hold it there and drive it and see if it still does it.
ON EDIT: If this is a 5.9 it has the P7100 inline pump, they rarely if ever fail.
 

·
Registered
Joined
·
349 Posts
Discussion Starter · #8 ·
would you be willing to sell this unit if its fixed?
Yes, my Dad and I have been trying to sell the truck for about 7 months now. I think he will take 70k for the rig. You can call me if you want the details. 832-347-8703
 

·
Registered
Joined
·
349 Posts
Discussion Starter · #9 ·
Got the truck fixed yesterday. There was a prebowl to the fuel filter that was full of rust from the bottom of the tank. Dropped the bowl and cleaned the silk screen.

Thanks for everybodies input,
Mike
 

·
Registered
Joined
·
1,880 Posts
It's great when you find the culprit and it only costs you little elbow grease! Glad to see you found it!
 
1 - 10 of 10 Posts
Top