Diesel Place banner

1 - 13 of 13 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1 (Edited by Moderator)
I’ve been asking a few of you throughout this rebuild for pointers. I appreciate it all...this place is great. Here’s what happened...
93 599 block sheared woodruff key broke crank. Got a 97 506 complete as a donor with 140k on it. All new gaskets...cleaned valves...new valve seals...old heads on new block...arp studs...put my fluidampr and Leroy pulley on...etc.

Fired her up and started great with no smoke. Seemed rough. Retarded the timing a bit...seemed to help but still rough. Almost a vibration at higher rpm. The more I listen the more it seems like a fuel issue but my air dog puts out...just did FTB ...all injector lines are squirting fuel...injectors were new when the other engine blew.

Just saw I put my flex plate on backwards...dumba$$! Just can’t see that causing that much vibration...

And GO!......
 

·
Administrator
Joined
·
15,663 Posts

·
Registered
Joined
·
3,930 Posts
Flexplate must be on correctly. It probably will cause a balance problem.
The balance weight should be on the engine side.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #4
If I can figure out how to upload videos from my phone...I will
 

·
Administrator
Joined
·
15,663 Posts
If I can figure out how to upload videos from my phone...I will
The best way to post videos here is to first upload the video to Youtube and then copy the video link from the address bar and paste it here in the forum post.

:thumb:
 

·
Registered
Joined
·
20 Posts
Discussion Starter #6 (Edited by Moderator)
See if this works...

 

·
Registered
Joined
·
20 Posts
Discussion Starter #7 (Edited by Moderator)
Another view...

 

·
Registered
Joined
·
7,380 Posts
Engine will vibrate with a flywheel that is externally balanced put on wrong. Having stated that,> Is it even possible to install the flywheel on backwards since one of the crank bolt holes is offset?
 

·
Registered
Joined
·
318 Posts
That sounds exactly like my truck did just before I found out a push rod had worn through a rocker and was no longer opening my intake valve.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #12
Well I know my rockers are good... just had them off. I did the bolt replacement for those retainer buttons as well. Replaced the flex plate...it fixed the issue I was feeling. I took her for a drive and the down pipe was beating against the frame so bad it was annoying. For some reason the exhaust was like an inch back from how it lined up before...:wtf:
I wedged a paint stick I had in my truck in there and it helped tremendously...but shook loose after about 20 miles...but at least I know what the noise is. It still has the rough idle(same as video) and I also noticed the tensioner bouncing as well. In driving....I almost think there is a weak injector or a missing on...like maybe intermittent fires...

It takes time to chase stuff down with any new build...I’ll keep y’all up to date. I’m going on vaca now when all I wanna do is play with my truck:mad:
 

·
Administrator
Joined
·
15,663 Posts
Well I know my rockers are good... just had them off. I did the bolt replacement for those retainer buttons as well. Replaced the flex plate...it fixed the issue I was feeling. I took her for a drive and the down pipe was beating against the frame so bad it was annoying. For some reason the exhaust was like an inch back from how it lined up before...:wtf:
I wedged a paint stick I had in my truck in there and it helped tremendously...but shook loose after about 20 miles...but at least I know what the noise is. It still has the rough idle(same as video) and I also noticed the tensioner bouncing as well. In driving....I almost think there is a weak injector or a missing on...like maybe intermittent fires...

It takes time to chase stuff down with any new build...I’ll keep y’all up to date. I’m going on vaca now when all I wanna do is play with my truck:mad:
Inspect the motor mounts.
Worn motor mounts can be a source of the problem
 
1 - 13 of 13 Posts
Top