Diesel Place banner

1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
When I'm driving at highway speeds, my yukon consistantly sputters briefly between 62 & 68 mph. It's not constant but it happens every time I am entering that speed range on slowing from higher speeds. Never happens below 62 and never above 68, but will always do it at least once each time I am in the 62-68 mph range. Any Ideas?
 

·
Registered
Joined
·
1,620 Posts
Have you got a cruise control?

If so try that.
 

·
Registered
Joined
·
1,624 Posts
when you say sputter, do you mean a quick bonk or something that lasts more than a second?
 

·
Registered
Joined
·
287 Posts
I think im havin the same problem, it just feels like you hit a bump or something except you obviosuly dont, just a split second but very noticeable. and it happens around the same mph.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Scrufdog;1597005; said:
when you say sputter, do you mean a quick bonk or something that lasts more than a second?

Yes, it is just a quick bonk and then returns to normal.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
I do have Cruise control, but it has not been on during these episodes because traffic situations. Usually i'm doing 70 + when I use the Cruise control.
 

·
Registered
Joined
·
8,014 Posts
Try different speeds with the cruise control as it takes the APP module out of the loop and controls speed thru PCM control, and helps determine if problem is with fuel delivery or or the APP module on the accelerator
 

·
Registered
Joined
·
23 Posts
i have the same exact problem. the thing is, i also get it at when it reaches above 2000 rpm.... cruise control doesn't always work at those high speeds.
 

·
Registered
Joined
·
1,182 Posts
Mine has hiccuped 3 times in the last week. Doesn't seem to matter what my speed is. It's done it in town and on the highway today. It has only done it when I'm under heavy load, passin' a car or takin' off hard from a stop. I'm thinkin' fuel delivery for me.
 

·
Registered
Joined
·
23 Posts
today i changed/cleaned the air filter....my symtoms are not all gone, but bearly noticcable.. try it.
 
1 - 10 of 10 Posts
Top