Diesel Place banner

1 - 11 of 11 Posts

·
Registered
Joined
·
208 Posts
Discussion Starter #1
I installed the finger stick from JK about a year ago when I also installed the exhaust. No codes all that time and all of a sudden It is throwing the MAF just about everytime I start it? I checked my connections and they seem OK. Any ideas??:(
 

·
Registered
Joined
·
304 Posts
05'Max;1562783; said:
I installed the finger stick from JK about a year ago when I also installed the exhaust. No codes all that time and all of a sudden It is throwing the MAF just about everytime I start it? I checked my connections and they seem OK. Any ideas??:(

Dirty mas air flow sensor..Get some electrical contact cleaner..
 

·
Registered
Joined
·
1,303 Posts
Predator 2.02 on 65hp? Mine does this all the time. Supposedly something about the Predator program. No effect on performance as far as I can tell.
 

·
Registered
Joined
·
564 Posts
I have the same problem but my Finger Stick just started acting up. I keep throwing a P0103 Code. I have no clue why. When I take the finger stick out of the equation everything works fine. :( I've emailed JK and Fingers about the issues.

I'm getting ready to scrap the Finger Stick and run the Blocker plate w/o it.
 

·
Registered
Joined
·
304 Posts
DINO ONE;1563822; said:
I have the same problem but my Finger Stick just started acting up. I keep throwing a P0103 Code. I have no clue why. When I take the finger stick out of the equation everything works fine. :( I've emailed JK and Fingers about the issues.

I'm getting ready to scrap the Finger Stick and run the Blocker plate w/o it.

I have the finger stick out right now and still get the p0103..So i am thinking it is something else..i also am running an efi live tune so it might not be the tune..Just figured i would through that at you before you do anything..
sean
 

·
Registered
Joined
·
208 Posts
Discussion Starter #6
Maf

Easy to reset but a pain for sure. Thanks fellers.....
 

·
Registered
Joined
·
378 Posts
Not trying to be smart but I had the same problem. one day by accident I touched the MAF sensor when I was trying to clean it and I noticed one of screws was slightly loose. I tighten it now, no problem for past 4-5 weeks. I guess the engine rattle was tickling it!
 

·
Registered
Joined
·
208 Posts
Discussion Starter #9
MAP code

Well, I pulled the plug on the EGR and cleaned the connections and what do ya know? Not thrown a code since.......
 

·
Registered
Joined
·
335 Posts
I've run a blocker plate with no finger stick for over a month now with no codes. I guess I'm one of the lucky ones :D
 
1 - 11 of 11 Posts
Top