Diesel Place banner

1 - 4 of 4 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
My 6.5 runs great, has plenty of power. Just a couple problems... First diesel so bare w/ me please. First- light colored smoke- and a lot of it - for about ten or fifteen seconds after start up when cold. Injectors? second... once warmed up, very low oil pressure at Idle. Fine when driving. Gas, I know. Diesel I'm lost... any help appreciated.. Oh yeah about 40 k on a rebuild. Thanks
 

·
Registered
Joined
·
187 Posts
Welcome David. First and foremost before half a dozen others will tell you, go to the "Sticky's" and read the welcome new member and FAQ's and fill out your truck signature, so that everyone here will know what year truck you have and any mods that might have been done. You can see my sig at bottom of the reply. As for light smoke at start up, I would guess glow plugs are not up to par. There is a section of FAQ that can step you thru checking those out. As for oil pressure, just how little is too little. At normal running temps my truck holds around 20 psi at idle and just under 40psi while driving. Of course how accurate is the OEM guage, who knows. There should be several others that can help you out more than I can. I am new to the diesel scene also. Just purchased mine back in Decemeber.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #3
When I say "light" smoke, I mean light colored, not just a little bit. The pressuer is Very low. "check gauges" low. It usually happens after highway driving. I can drive it around town till it's warm and it's less likely. I'm thinking It's a bit overfilled and frothing oil. I hope not. As I said, the engine's a rebuild with around forty k on it. I love the truck. I decided on diesel because I'm using it as a work truck, startng a business that will require some light hauling and on rare occasions, fairly heavy towing. It will also double as my "boat hauler" and since i live in Vegas, it's freaking HOT here in the summer. I just figure a diesel's more apt to handle the hard use. Thaks for the rply. I'll look on that "sticky" section and update.
 

·
Registered
Joined
·
187 Posts
Yes the color of the smoke. Mine does the same thing. My glow plugs are weak and need replaced.

In the FAQ's you will probably read about the OPS 'oil pressure switch'. These things tend to go bad. The OPS also controls your fuel lift pump which helps supply the fuel to the IP. One way to see if the lift pump is working is to open the T-valve and see if a constant stream of fuel comes out of the drain hose. You might want to use a quart jar or something to catch that $$$$$ expensive fuel. If there is no fuel then you probably have an issue with the OPS and possibly the lift pump. On a freshly purchased 6.5TD it is usually a good idea to replace the OPS, lift pump, fuel filter, and CTS 'coolant Temperature Sensor' located close to the T-stat, it will have two wires running to it. Just some good preventative maintenance.
 
1 - 4 of 4 Posts
Top