Diesel Place banner

1 - 15 of 15 Posts

·
Registered
Joined
·
1,673 Posts
Discussion Starter #1
Noticed it about 2 days ago. When the truck is running less than 1500rpm's the oil pressure drops the the 30 mark and when I roll on it it will climb back to 60 when it gets to 2000rpm's and holds just over 60 when I get it above 2000rpm's. I was going to Tahoe today and the TC was locked in 5th, running 1500rpm's and I was only getting 30 on the oil pressure. Cheaked the oil and it is on the full mark, does not smell like diesel. Changed the oil and filter 3500 miles ago.

Does anyone have any ideas? Could it just be the guage or am I looking at a potentially serious problem? Truck just turned over to 62000 miles. I am running Chevron Delo 400 15-40 and a Napa Gold filter. It was 32 degrees outside and engine temp was up around 185.

Thanks,
Bentley
 

·
Registered
Joined
·
18 Posts
Ive noticed that on my 04, never thought much about it though. All my old chevys do that too. as long as you are on the full mark and running the grade oil GM recomends I wouldnt worry about.
 

·
Registered
Joined
·
142 Posts
That is about what I have also:
Idle warm: 30
1800 rpm and above 60

They did something to the '03 engine that lowers the oil pressure. I also have a '02 3500 that runs much higher oil pressure all the time.
 

·
Registered
Joined
·
86 Posts
Low Oil Pressure

I had my cluster replace a few weeks ago, when i got the truck back my oil press was maxed out on any RPM over idel, as well I did not seem to have all my functions on my DIC. I phoned the stealer and asked what was going on, they told me they must have put in the wrong programming. The next week I take it back they program it again and everthing is back to normal.
My point though is not that your oil press is low (or high) it is that they can make it read anthing they want, so the darn numbers really don't mean anything, other than you have pressure.

hmmmmm............... GM's kinda like the ford oil press gage now -:t



Kelly
 

·
Registered
Joined
·
58 Posts
Whew, am I glad I found this post. I just bought a used '02 today, and didn't notice that during the test drive, but when I got it home I noticed my oil pressure guage doing the same thing.
 

·
Registered
Joined
·
16,971 Posts
Very normal, mine does it as well and has since day one. Will usually run a little higher right after oil change but then settles back down after that..
 

·
Premium Member
Joined
·
20,561 Posts
I had my cluster replace a few weeks ago, when i got the truck back my oil press was maxed out on any RPM over idel, as well I did not seem to have all my functions on my DIC. I phoned the stealer and asked what was going on, they told me they must have put in the wrong programming. The next week I take it back they program it again and everthing is back to normal.
My point though is not that your oil press is low (or high) it is that they can make it read anthing they want, so the darn numbers really don't mean anything, other than you have pressure.

hmmmmm............... GM's kinda like the ford oil press gage now -:t



Kelly
EXACT SAME THING happend to me. Tranny temp gauge backlight burnt out, dealer replaced cluster under warentee...when I got the truck back it read like ~110 psi oil press at idle, and I had no Overdrive lockout, no high idle, no fuel filter life etc. I took it back, they reprogrammed it and its all good now.

Ben
 

·
Premium Member
Joined
·
20,561 Posts
Ive found the GM gauges to be fairly accurate (when actual Tech 2 reading is compared with gauge reading)...much better than the Ford idiot lights-I mean gauges. :)
 

·
Registered
Joined
·
1,216 Posts
Have to agree about the Furd gauge. During the 4-1/2 months I owned one of those things, complained to the zone rep about the oil pressure not changing with engine RPM. Was informed at that time that the "gauge" is fed by a pressure SWITCH, not an analog sensor. Further enforces that at least they had enough sense to put a circle around the problem!
 

·
Registered
Joined
·
4,132 Posts
I AM EXPERIANCING THE SAME DEAL, RUMOR HAS IT IS THERE WERE SOME TSBS ON THE OIL PSI READING LOW, MINE IS ALOT LOWERE THN I LIKE TO SEE. 15 AT IDLE WHAEN IT WAS 30 AND I CANT GET IT TO HIT 60 NO MATTER WHAT I DO 110 MPH AT 34 LBSBOOST 35TO 40 PSI MAX PRESURE WHEN IT WOULD GO TO 65 70
. i WILL LOOK INTO THIS AS CLUSTERS HAVE BEEN RECALLED ALSO.
 

·
Registered
Joined
·
7 Posts
I picked up my truck 2 days ago. I noticed the oil pressure gauge shows 60 at start, 15-20 when warm. Ramps up to 30-40 in town driving, and 60 on the highway.

Should I be concerned about the low pressure reading during warm idle?
 

·
Registered
Joined
·
397 Posts
I picked up my truck 2 days ago. I noticed the oil pressure gauge shows 60 at start, 15-20 when warm. Ramps up to 30-40 in town driving, and 60 on the highway.

Should I be concerned about the low pressure reading during warm idle?

No!
Mine dropped alot after I installed the FS2500 oil filtration system. I was 30-40 at idle and it dropped to 15-20. It's been that way since 7500 miles, now at 44K no problems.
Doug
 
1 - 15 of 15 Posts
Top