Diesel Place banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Check gages lights up when braking, even at slow speeds. Just had the ops replaced, new oil and filter. I used omega 907 flusher before this oil change to get the worst sluggy stuff out. Still I get the check gage light. I removed this filter recently.(pic) Its a 99 6.5. Sidenote: on top of the inlet, there's a black box and a plug, anyone know what that is? And maybe the pros recogn7ze the engine from the pic.
635404
 

Attachments

·
Administrator
Joined
·
16,750 Posts
Check gages lights up when braking, even at slow speeds. Just had the ops replaced, new oil and filter. I used omega 907 flusher before this oil change to get the worst sluggy stuff out. Still I get the check gage light. I removed this filter recently.(pic) Its a 99 6.5. Sidenote: on top of the inlet, there's a black box and a plug, anyone know what that is? And maybe the pros recogn7ze the engine from the pic.
When you replaced the OPS did you install an AC/Delco Brand OPS? Aftermarket electrical parts will bring gremlins in a 6.5L
With sludge like that it is best to run a can of Seafoam through your oil system. Pour it in, drive for 30-1hr. then change your oil and filter.
You may have to do a couple of treatments like that to get rid of most of that sludge.
The black box you mention in the pic is the boost/MAP sensor from your "S" VIN 6.5L w/ EGR, engine you are showing in the pic.
 

·
Premium Member
1995 Chevrolet Silverado Z71 6.5 TD
Joined
·
197 Posts
That sludge there is ridiculous. Is your engine knocking at all?
 
1 - 4 of 4 Posts
Top