Diesel Place banner

1 - 4 of 4 Posts

·
Registered
Joined
·
126 Posts
Discussion Starter #1
Hi guys and gals,
Been a long time reader and decided to ask my first question.... My dad owns the truck you see in the sig. (It's about to be mine
after I get rid of the 94 Nissan that I'm currently driving.)

The low coolent light comes on often while driving. He never has to add any water, no white smoke on startup. The truck has been pampered it's whole life, never driven over 65mph and never had any problems with it running hot.

Everyone he's asked has said it could be a faulty switch. I though I might try to clear this up before I inherit a problem.

thanks all!
 

·
Registered
Joined
·
1,922 Posts
lights usually go on for a reason.. first off check all your fuses.. could be that simple......when mine goes off and on/ I have a leak somewhere..... or low fluid.. check and dbl check all your hoses.. also throw in some barsleak into the overfill it will clear up any unseen holes.. good for it too..follow directions on the bottle................ new heads are really expensive...........;)
 

·
Registered
Joined
·
198 Posts
Mine pretty much stays on too. Never needs coolant. My thought is the sensor is gunked up. Our band bus did this (Eagle w/2stroke d/d) and they removed sensor and wiped it off problem went away.
 

·
Registered
Joined
·
7,135 Posts
Another consideration could be air trapped in the top of the radiator. I always remove the hose that goes from the top of the radiator to the coolant degas bottle when purging air from the system. The top of the radiator will trap air and this will allow the level in the bottle to change alot during t-stat cycling and heating.
 
1 - 4 of 4 Posts
Top