Diesel Place banner

1 - 20 of 30 Posts

·
Premium Member
Joined
·
9,403 Posts
Discussion Starter #1
:( I've lost like 3-5mpg :( :mad: in the last two weeks and my power seems to come and go. Part of the it pulls mormal and part of the time it won't hold speed with my trailer.I have never gotten less than 11mpg pulling up to 20k. This weekend I pulled a 8k load 600 miles and got around 8-9mpg :eek:: . I called the dealer and they said there was nothing they could do and that that milege sounded normal :rolleyes: . This is probably the injectors going bad right.The filter was just changed so it's not that. I need help asap.
 

·
Premium Member
Joined
·
9,403 Posts
Discussion Starter #3
They were replaced at 87k and I now have 113k.
 

·
Registered
Joined
·
12,950 Posts
It is my understanding that if the injectors go bad, they exhibit a lot of other symptons.......like hard starting, run bad, smoking, etc.
 

·
Premium Member
Joined
·
9,403 Posts
Discussion Starter #5
:help: Anyone else have any ideas? :(
 

·
Registered
Joined
·
1,311 Posts
The only other ideas I have is a short somewhere, you say it comes and goes, that or your ecm is going.
 

·
Registered
Joined
·
408 Posts
FPRV? I had a friend that had his go south and it caused similar results. Does the SES come on? What does it do exactly when it loses power?
 

·
Registered
Joined
·
151 Posts
It is my understanding that if the injectors go bad, they exhibit a lot of other symptons.......like hard starting, run bad, smoking, etc.
I just lost the number 6 and 7 injector recently. Absolutely no warning, rough idling, smoking, etc. Just found out as I pulled out to pass a slow moving car, and couldn't get over 2,000 rpm. Limped home at 65 mph max, for 250 miles, and into the dealer. Just my experience, but no warning at all......
 

·
Registered
Joined
·
626 Posts
Service Engine Soon, you might check the MAF sensor or the air cleaner.
 

·
Premium Member
Joined
·
9,403 Posts
Discussion Starter #12
No SES light.Part of time it will hold speed and part of the time it won't.This is with a trailer. I'm going to change the air cleaner because it's time.
 

·
Registered
Joined
·
1,238 Posts
its possible your injectors could be bad again, but not likely. Check the fuel flow again. If you got a bad load of fuel you may go through a couple filters, which really sucks. Only time mine would not hold speed was when my filter has been clogged. I have had 2 sets of injectors and never noticed a lack of power, just more smoke. Have a shop put it on a tech2 and get the balance rates. Search the this site for the correct balance rate numbers.
 

·
Premium Member
Joined
·
9,403 Posts
Discussion Starter #14
Well I still don't know anything.:( I'm going to take it to the dealer next week and see if they can figure it out.
 

·
Premium Member
Joined
·
9,403 Posts
Discussion Starter #16
Today I jerked the VA out because I was told it may reset something :confused: .Anyway I figured with the VA out it should act the same way as with the VA off,not so.Absolutely no power with it out :eek:: .It can't even gain speed on small hills empty :mad: :eek:: . I'm starting to get a little :mad: .I threw the VA back in after 55 or so miles. I'm getting a new air filter and a new fuel filter asap but I think there is more.
 

·
Registered
Joined
·
209 Posts
I just got back from Miami towing 8k and was getting 8 mpg. I couldn't hold 5th gear across alligator alley, which is extremely flat. So I stopped in Ft. Myers and took the tune out and it went down to 7 mpg and was a turd the rest of the trip. I will take it in tomorrow to the dealer. The mech. there I deal with has always been pretty straight with me so I will post my results.
 

·
Premium Member
Joined
·
9,403 Posts
Discussion Starter #18
That's almost exactly the way mine is acting :confused: .And I was towing close to 8k when I observed the 9mpg :eek:: .I just haven't had time to get mine in yet.I'm anxious to hear what it is.Hope it's a simple fix.
 

·
Registered
Joined
·
209 Posts
Well, he scanned the truck and found nothing. Said the filter was extremely dirty and I hadn't had my recall done yet, so he changed it and said to watch it for results. I would say that he is full of it, however it's not showing any real signs of injector failure and no SES light. I'm going to run a tank of gas without towing and see what happens. When was the last time you changed your fuel filter "01Duramax6spd".
 

·
Premium Member
Joined
·
9,403 Posts
Discussion Starter #20
I had mine done on recall 1500-2500 miles back.I went into town yesterday {40 miles} and couldn't even hold speed empty :mad:. I was very unhappy. We need to find out what is up,yesterday!!! I'll take mine in and see what they say.
 
1 - 20 of 30 Posts
Top