Diesel Place banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
So i am having a problem with my 02 lb7. Losing coolant after filling it up only after a couple weeks. Smokes a little at idle but not bad. I do run about 100hp tune. Injector readings are all fine. It does leak a very small spot under truck after parked. But not big enough to lose as much coolant as it does.
 

·
Registered
Joined
·
40 Posts
I am losing coolant also, on back of engine. Appears to be coming from turbo. No smoke. A friend had the same problem from his turbo. /both trucks 02 lb7's
 

·
Registered
02 2500HD LB7
Joined
·
94 Posts
There are small coolant lines (like 3/8") going to the turbo that have 3 rubber sections in them that are most likely your problem.Two up by the turbo and one small straight piece behind the fan pulley that returns it near the water pump housing. My returns were like jelly from the heat when I replaced them last year.
 

·
Registered
Joined
·
40 Posts
Had my 02 2500HD checked, wasn't the turbo. The oil cooler is leaking coolant. This cooler is where the oil filter
connects to the engine. Waiting for parts.
 

·
Registered
02 2500HD LB7
Joined
·
94 Posts
I would still do the turbo lines if they are original. The connection back to the water pump on mine decided to let go in February as I pulled into the driveway one night, luckily it wasn't very cold that night so I was able to fix it outside. The return line right off the turbo was mush when I changed it last summer, surprised it hadn't popped yet.
 
1 - 5 of 5 Posts
Top