Diesel Place banner

1 - 11 of 11 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
does anyone have the edge w/attitude? and how do you run this thing on level 5 and still drive normal. this thing is crazy on level 5. most of the time i have just left it in level 2-3. my ? is this. i have the pyro probe in the downpipe just past the turbo not on the manifold like the instructions tell you to install at. (bought it used and it had the probe already installed when i got the edge) anyways the edge company told me to just put the alert for EGT on 1000 deg instead of 1350 because the probe was further down the tube because they say that the exhaust will be hotter at the manifold than at the downpipe by about 300-350 deg. i was hauling a little car on a trailor and the alert was going off all the time going up hill on level 2. was i pushing it to much? or do i need to up the alert a little more to maybe 1100 or 1150 deg. truck is stock except for the edge w/ attitude and the intake has a bigger K&N filter thanks for the info in advance

james
 

·
Registered
Joined
·
11,311 Posts
Thousands of members here run Edge products. However, running it on level 5 will fry your stock tranny. Its way too much power for that tranny and torque converter to handle.

Most people see temps at around 700-900 degrees while running tuned at a steady highway cruise. Seeing temps of 1200-1300 is normal for towing any sizeable load. Most people have theirs set for around 1350-1400. A brief spike to 1400 isnt that big of a deal. Running sustained temps for a long period is asking for trouble.
 

·
Registered
Joined
·
712 Posts
You could also think of putting a free flow exhaust on your truck, I am looking at a Jardine on E-bay that are good prices. Search under (jardine duramax)
 

·
Registered
Joined
·
239 Posts
Unless you upgrade your tranny I would not run it above 2. I have put mine in limp mode 3 times in level 3/3 just hitting the pedal to pass. If you have not limped it yet you are in for a little scare the 1st time it happens. I would put the probe in the correct location.
 

·
Registered
Joined
·
90 Posts
I wouldn't run on level 5 with a stock trans unless you plan on upgrading it soon. I would also think about relocating your pyro probe to the correct location instead of guessing what the egt's are. It is very easy to drill and tap, you can do a search for the "Hoot method" in the "do it yourself section" and have it relocated in about 1/2 an hour.
 

·
Registered
Joined
·
298 Posts
I too have Edge W/ Att, have limped on third setting. i def. recommend full intake and exhaust for the temp problem, edge recommends that with heavier loads to use the 1st or stock tune also. Stage 5 is nice but watch urself!!!!
 

·
Registered
Joined
·
239 Posts
Called Edge yesterday, new update coming out in month......FYI. I have version 1.2 I think and the new 1 will be 2.3, been checking the web site but never could tell if I needed update.
 

·
Registered
Joined
·
692 Posts
So they have an update for this unit. What is the cost to upgrade. I have a used one that I'm going to sell, would upgrade it if price is right first.

Don't run over level 3, limped mine twice, just have to be careful in 5th gear.
 

·
Registered
Joined
·
239 Posts
No charge but shipping. Check there site, they have a form for you to print (fill out) and send in with the Edge.
 

·
Registered
Joined
·
239 Posts
MikeL advises that most likely the C3 clutch is damaged (possibly C2 & C4 as well) when you limp it. I took mine to dealor today (that installed Edge), they ofcourse checked the codes and drained the fluid. They said no color change in fluid....Blah.....Blah and so on so they think it was the Edge causing the code (no crap, can you say to much torque in 5th gear) so want to send it back to get it checked out. I advised them of all the info I had gathered (on this forum from all the knowledgeable people) and exactly what the issue was but they just don't understand I guess. They unplugged it and I didn't get to talk with them since I picked it up after they closed. I guess I will send Edge back next month to get the new updates. What I thought we had agreed upon was a tear down and inspection of the clutches and replacement if damaged but I guess they misunderstood. I guess I will just have to pay for the upgrades when I can afford it but was hoping that I wouldn't have to pay for the clutch replacement (if need be). They advised me they would warranty evrything but if they don't understand I guess it's hard.
 

·
Registered
Joined
·
692 Posts
Mine went about 20,000 miles from the 1st time it happen to the 2nd. jsut have to watch the go pedal in 5th gear on that level. other wise it will be fine.
 
1 - 11 of 11 Posts
Top