Diesel Place banner

1 - 20 of 23 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
2004 2500HD LLY Max/Allison w/Edge and Attitude, 11,500 miles, crew cab/long bed - nothing quick about this truck coming off the line for approx 5 seconds, then the chip kicks in and it raps. While I'm not a hotrodder, not even a chirp from the tires unless I go thru water. Hook up the 40' weekend warrior 5th wheel and the hesitation becomes a major issue - slow easy takeoffs are no problem. But try to accelerate thru a left turn and it's fill-my-pants time - when the truck is thru the intersection (obviously there's 40' behind me that's NOT), the chip kicks in and the trans can barely keep up, with hard chassis-jarring shifts thru 2nd and 3rd gear. I wanted a 7.3 Pwrstroker but Ford changed to their own lousy 6.0, so went to the Max. Dealer says it checks out within specs. On the road, this thing rides great, has plenty of power (except an occasional hard downshift - glad I bought the warranty), and unhitched gets 25mpg at 77 mph. HELP!!!
 

·
Registered
Joined
·
1,074 Posts
2004 2500HD LLY Max/Allison w/Edge and Attitude, 11,500 miles, crew cab/long bed - nothing quick about this truck coming off the line for approx 5 seconds, then the chip kicks in and it raps. While I'm not a hotrodder, not even a chirp from the tires unless I go thru water. Hook up the 40' weekend warrior 5th wheel and the hesitation becomes a major issue - slow easy takeoffs are no problem. But try to accelerate thru a left turn and it's fill-my-pants time - when the truck is thru the intersection (obviously there's 40' behind me that's NOT), the chip kicks in and the trans can barely keep up, with hard chassis-jarring shifts thru 2nd and 3rd gear. I wanted a 7.3 Pwrstroker but Ford changed to their own lousy 6.0, so went to the Max. Dealer says it checks out within specs. On the road, this thing rides great, has plenty of power (except an occasional hard downshift - glad I bought the warranty), and unhitched gets 25mpg at 77 mph. HELP!!!
PM sent
 

·
Registered
Joined
·
1,545 Posts
how the ..... are you getting 24 doing 77. I get like 17.6 doing 80.
He's probably running a tune (Predator in sig) and using the DIC to calc mileage. The DIC is not accurate when running a tune. The DIC (AVG ECON) will read much higher when running a performance tune.
 

·
Registered
Joined
·
5,130 Posts
He's probably running a tune (Predator in sig) and using the DIC to calc mileage. The DIC is not accurate when running a tune. The DIC (AVG ECON) will read much higher when running a performance tune.
Yeah, mine shows 45mpg at 85mph, I am confident it is wrong :)

.
 

·
Registered
Joined
·
5,130 Posts
2004 2500HD LLY Max/Allison w/Edge and Attitude, 11,500 miles, crew cab/long bed - nothing quick about this truck coming off the line for approx 5 seconds, then the chip kicks in and it raps. While I'm not a hotrodder, not even a chirp from the tires unless I go thru water. Hook up the 40' weekend warrior 5th wheel and the hesitation becomes a major issue - slow easy takeoffs are no problem. But try to accelerate thru a left turn and it's fill-my-pants time - when the truck is thru the intersection (obviously there's 40' behind me that's NOT), the chip kicks in and the trans can barely keep up, with hard chassis-jarring shifts thru 2nd and 3rd gear. I wanted a 7.3 Pwrstroker but Ford changed to their own lousy 6.0, so went to the Max. Dealer says it checks out within specs. On the road, this thing rides great, has plenty of power (except an occasional hard downshift - glad I bought the warranty), and unhitched gets 25mpg at 77 mph. HELP!!!
Not sure what tune you run, but my truck runs nothing like that. It will lay waste to the tires from a stop, and lays down tracks in second. It will spin the tires and chirp them from stomps down below 10mph. If I am towing and give it to much throttle I get wheelspin, and again into the second gear shift. There surely isn't a 5 second wait. Maybe your EGR is closing slowly?

Your MPG figures are off, the DIC is not accurate after tuning is applied, be it a box or a programmer.

.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #8
re mileage - calc'd the old fashioned way, miles driven divided by gallons at fill-up. October 2005, driving south on I-15, Idaho to California, 3 consecutive fillups +/- .5 mpg, avg 25. I wouldn't've believed it if I hadn't seen it myself. Remember the cat is gone, and I've opened the in/out as much as possible without going extreme. Stock tires, with chip turned off (mode 0). I didn't notice a tail-wind, and I wasn't drafting, so go figure. I didn't write to brag, I was hoping that someone might have had a similar experience and knew what the problem was. Perhaps there's a connection with great mileage and poor acceleration - yet I have decent acceleration when I'm rolling. My wallet benefits, so at least there's something positive with the truck (remember I'm a Ford guy).

My previous ride, 2000 E-350 Powerstroke (vans have no intercooler, so less horsies), had 4-bbl punch after I added a Western Diesel chip, but could never get more than 13 mpg out of it.

Re slow egr - how would I determine that?
 

·
Registered
Joined
·
27 Posts
Farmallmark, Mine is extremely doggie also. No problem pulling a load but no spin when empty unless on wet pavement. I am running stock however. In fact I feel no need for the second half of the fuel pedal as it makes little difference when used. Wonder if I am experiencing an issue I am not familiar with. This is my first diesel so nothing to compare to personally.

TXChristopher, what additions/tuner are you using in yours. Didn't see any in your sig. Sounds like you have it setup well. I'm also in the Houston/Spring area so fuel should be about the same.
 

·
Registered
Joined
·
352 Posts
I have the same problem. When I'm at a complete stop and stomp it to the floor it seems like it takes a few seconds to respond then it takes off. But I have no wheel spin at all. This is in level 3/5 and I've even tried 4/5 with the same results. My edge is the 1.0, I wonder if this is the problem? Any suggestions cause like Bluestreak, this is my first experience with this stuff.
 

·
Registered
Joined
·
311 Posts
MIne does the same thing from a stop. By the time it hits 2nd, depending what the 6 gun is on, it may break tires loose on pavement.
 

·
Registered
Joined
·
282 Posts
My truck was kind of the same way, but when I put on the boost stick it made a major difference.
 

·
Registered
Joined
·
135 Posts
Sounds like turbo lag to me.....
 

·
Registered
Joined
·
1,458 Posts
On the Edge Programmer, do you have the low boost fuel set on 5? That will make a difference. On my old LB7, I had that programmer, and I put the Low Boost Fuel program on 5 and ran the main program on 2 and it ran like a beast. It would howl the hides any time. Check that out as see if that helps. Mine would blow black smoke off the line, and then clean up as the turbo spooled. Didn't get anywhere near 23mpg, but then, niether does my stock LLY.
 

·
Registered
Joined
·
352 Posts
Yes, I got the low boost at 5
 

·
Registered
Joined
·
248 Posts

·
Registered
Joined
·
726 Posts
Later Model Duramax's Specifically Engine Code Rpo "lly" Have Experienced Numerous Problems With The Addition Of Aftermarket Performance Tunes, Modules, Etc. Most Problems Arise From A "1093" Code Or "low Fuel Rail Pressure At Idle" Also A 1094 Code Which Is Also A Low Fuel Rail Pressure Code. This Is Caused By Fuel Starvation, The Performance Tune Makes The Engine Demand Higher Fuel Rail Pressure And The Actual Pressure Regulator Located At The End Of The Drivers Side Fuel Rail Is The Culprit. This Regulator Will Only Allow Factory Fuel Pressure And Flow, When The Computer Demands Additional Pressure And Flow The Regulator Cannot Handle This And It Sets A Low Pressure Code. To Elimnate This The Pressure Regulator Has To Be Shimmed, Or The Rails Have To Be Replaced With Performance High Flow Rails. Put Your Trucks On A Scanner And Retrieve The Dtc's. I Am Willing To Bet You Get A 1093, 1094 Or A Cylinder Missfire, If The Missfire Is The Case You Probably Have A Malfunctioning Fuel Injector, Not That Uncommon. But If You Have A 1093 Or 1094 Code You Can Order The Fuel Rail Shim Kit From Pacific Performance Engineering At ******************
 

·
Registered
Joined
·
4 Posts
Discussion Starter #19
Mine's had the hesitation/lag from mile 2 - my test drive.

I'll check the low boost fuel setting on my Attitude, but don't see how that could be the culprit running on "0", stock. Might help in tow mode!

My05Duramax - what's a "boost stick" and where did you get it?
 
1 - 20 of 23 Posts
Top