Diesel Place banner

1 - 9 of 9 Posts

·
Registered
Joined
·
77 Posts
Discussion Starter · #1 ·
i just put in the j/a it was easy to do i have a 03' crew cab short bed with mbrp 4"exaust and volant intake. i have tried all 5 power levels. on level 3 i ran a 7.0 0-60 and a 15.7 1/4mile w/ 2 other people. levels 4-5 are nice but 5 is a little scary from reading the stories from the people on here. but even at 3/4 throttle it spins brand new bfg all terrians! anyway i just wanted to tell every one thatr doesnt know that the edge juice with attitude is the best thing u could buy for this thing imo. i almost injoy this truck as much as my 95 supercharged 6 speed impala ss.:ro)
 

·
Registered
Joined
·
1,152 Posts
That does it. I installed my J/A a couple of days a go. I don't get so much as a scratch from my tires on level four. Guess I better disconnect/reconnect before making a call. Attitude seems to be working, just don't feel the power I expected.
 

·
Registered
Joined
·
1,005 Posts
Farmdog ~ While I'm not into wasting good rubber ~ my first juice, v4.8i didn't compare to the V1.0 replacement unit. I'm guessing it had other issues beside the cold/first startup problem I was experiencing. It can pull some g's now.

BTW, back in the 90's there was a common exclaimation 'wudya look at the head on that puppy!'. Looking at your avatar ~ can't help but think it has finally come home :D :cool2:
 

·
Registered
Joined
·
1,152 Posts
Farmdog ~ While I'm not into wasting good rubber ~ my first juice, v4.8i didn't compare to the V1.0 replacement unit.

Say's v1.0 on juice; v1.30 on att. See my new post for rest of the story.
 

·
Registered
Joined
·
83 Posts
edge

i installed my edge/att today..........love it........big difference.....it was good truck before ........... now it is alive
 

·
Registered
Joined
·
6,504 Posts
Farmdog, you are letting it get up to operating temperature, right? The Edge will not fuel until engine temp gets up to at least 180 degrees.
 

·
Registered
Joined
·
12,950 Posts
That does it. I installed my J/A a couple of days a go. I don't get so much as a scratch from my tires on level four. Guess I better disconnect/reconnect before making a call. Attitude seems to be working, just don't feel the power I expected.
:exactly: I have increased power.....but definitely not the amount that I expected. Level 3 feels about like when the truck was new. Even on level 5, it does not cause the pos dmf/clutch to slip?:confused:
 

·
Registered
Joined
·
1,870 Posts
That is weird. My hypertech would smoke the tires if I power braked it. The Edge on my LLY would spin'em real good until my trans started slipping and not putting the power to the good.
 

·
Registered
Joined
·
1,870 Posts
Just didnt want to be stuck on post #66^
 
1 - 9 of 9 Posts
Top