Diesel Place banner
1 - 7 of 7 Posts

·
Registered
Joined
·
266 Posts
Discussion Starter · #1 ·
1 @ 3.5
2 @ 2.1
3 @ 2.1
4 @ 0.4
5 @ 2.3
6 @ 15 (not 1.5, but 15)
7 @ 5.4
8 @ 4.8
#6 code showing PO306C
warm at idle, in neutral.
 

·
Registered
Joined
·
266 Posts
Discussion Starter · #5 ·
mvnvltn;1545017; said:
Look at 7 and 8. What does the oil pressure read? Do you have any over-boost codes?
oil pressure is excellent, no overboost code, just the code I previously mentioned, no fuel in oil.
 

·
Registered
Joined
·
266 Posts
Discussion Starter · #9 · (Edited)
02freighttrain;1545966; said:
Tell us a little more if you can. Is it running rough? Any Smoke? I bent a pushrod once and it had the same inj bal as yours. Filling out your sig will give the experts here more info about your truck and they can offer more advice. Hope it's not serious.
Actually 02, it runs very smooth, no obvious signs of a dead cylinder. This is what had me confused when the tech informed me of the #6 code description. The truck is an 03, K&N intake, 4" banks exhaust, no tuner now, It's a "burger cruiser," no hot rod here ;-). I had the edge shut down on the EZ, long before this started. Level 2 was the highest it was ever set. 99,970 miles. Fuel filter changed every 5,000 miles (no lie) because I travel from NC to Baja, and am aware of the injector issues others have had. No codes other than the po306c. fuel pressure tested showed 4K+ @ idle (tech quote). Oil changed religiously every 3,000 miles, maintenance has always been a strong point for me, this is a big investment I'd like to last. I've used additives, Lucas fuel treatment. Egt's have never been above 1250, ever, and the 1250 was in a towing situation, light throttle. I honestly do not hammer this ride, it's my livelihood. I'm going to have to think no as far as valvetrain damages are concerned, I would believe there would be an obvious miss present. At this point, there is no fuel in the oil, mileage is ok, power however is hit and miss. Light sporadic smoking at idle has turned into constant smoking at idle now, just yesterday it was off and on. This is why I took the initial respondent's post seriously enough to have a balance check. On a side note, does the book actually show an 8 hour replacement time figure? Also, how would the cylinder be accessed for a compression test, as one poster mentioned?
 

·
Registered
Joined
·
266 Posts
Discussion Starter · #13 ·
02freighttrain;1546539; said:
What Scott said........ Your probably gonna get a waranty set of injectors out of this problem. Suck's to have your truck down but it's typical for the LB7's. I'm on my third set:eek: No pressure build-up in the cooling system, is there?
Cooling system seems fine, no overflow or pressure rise / spike. I spoke with the local dealer yesterday, eve. the writer suggested I bring the vehicle in, said it sounds like an injector failure. We'll see. Thank you all for responding, I appreciate it. I'll post a follow up as well.
 

·
Registered
Joined
·
266 Posts
Discussion Starter · #14 ·
Just returned back from the dealership, a good experience. They have ordered replacement injectors (all 8) and concurred the balance findings, although #6 was showing a good reading, number 3 took its place when put in gear. They have to be ordered, 1.5 - 2 weeks ETA, no problem. The tech had mentioned the replacements are rebuilt, which I could care less about, and they are also redesigned internally as far as the "rebuild" goes. He also stated he was very surprised they were able to reach 100K. There were no gripes about intake, exhaust, a previous tune, lift, etc. It went very nicely. I feel for others having a hard time getting things handled smoothly.
 

·
Registered
Joined
·
266 Posts
Discussion Starter · #17 ·
nay6;1547509; said:
They should give you a rental too if you need one. I got one with my injector change.
I'm thrilled not having to go through what other people have, they offered a reduced rate for a rental, which is fine. As far as I'm concerned, as long as the repairs are made competently, and the dealer stays "up front," I'm happy. Again, thanks for the excellent replies, and solid advice!!
 

·
Registered
Joined
·
266 Posts
Discussion Starter · #19 ·
[email protected];1547765; said:
I'm thrilled not having to go through what other people have, they offered a reduced rate for a rental, which is fine. As far as I'm concerned, as long as the repairs are made competently, and the dealer stays "up front," I'm happy. Again, thanks for the excellent replies, and solid advice!!
Seems I spoke too soon on this. After being told the injectors were in, and bringing the vehicle in after the appointment process, the vehicle is sitting, untouched, 5 days later. Why? Because the injectors are not in, the person who made the statement apparently never worked there........and after the service manager received my vehicle, stating how surprised she was at my "niceness", and guaranteeing it would be ready tuesday at the latest.......today, I now am told they do not know when any injectors can be had......I hate being lied to. Randy Marion gets my vote for "Too many chiefs, and not enough indians." So much for staying "Up front."
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top