Diesel Place banner

1 - 5 of 5 Posts

·
Registered
Joined
·
140 Posts
Discussion Starter #1
OK guys...... I did some searches on the forum and got a few ideas, but I still wanted to check with you all for clarification.


I am getting my truck modded as we speak, and the guy doing it for me just called. He is installing the AFE Stage II, Juice/Attitude and 4" exhaust. He told me he got as far as the intake and juice, and when he started the truck and got into the pedal, the truck died. Check Engine light came on. He unplugged the juice, everything works. He told me this happens some times, got a bad box. He's got another one coming next week, but I am wondering if maybe the fuel filter is dirty? I read a post here that may be the problem. If so, would the truck work well under stock conditions?


Just grasping at straws here. I really want this done. Got 2 months of research (and paychecks) and a serious amount of time reading all your posts. This is a great site. Lots of info.


BTW, got the 6" Fabtech going on tomorrow with RG1 17X8 rims and BFG 35's. Can't wait.
 

·
Registered
Joined
·
281 Posts
Sounds like your truck is really coming along.


But it does sound like you have a bad Juice box. It happens. You might want to check and see if any pins were bent when he installed it. That could be the problem too. Your fuel filter is fine.


Jesse
 

·
Vendor
Joined
·
9,676 Posts
Programming update in the works...
 

·
Registered
Joined
·
140 Posts
Discussion Starter #5
Thanks for the replies and advice! Guess for now I'll just have to wait a few days to feel the power everyone on this site is always talking about, after installing the juice/attitude. At least I'll have the look I want while I'm waiting. I don't have too much hair left to pull out anyway.......been doing that for two months now......
 
1 - 5 of 5 Posts
Top