Diesel Place banner

1 - 13 of 13 Posts

·
Registered
Joined
·
1,704 Posts
Discussion Starter #1
I had the 90 juice on now for almost a year and have been running it in the 90hp setting the entire time. Out of bordom the other day, I decided to try the other settings for the first time..............................they didnt work. None of them would work, and I couldnt even put it back to stock. What is wrong with it?
 

·
Registered
Joined
·
61 Posts
Bzzzzttttttt Sorry, Amberjack, the Juice carries it's last setting along for the ride when you remove it.


This sounds more like a procedural error. I found on my truck I had to physically start it up then turn it off one key click to the left before the pedal/shift combos would work. If the check engine light was on, it would not take.
 

·
Registered
Joined
·
12,262 Posts
Probably a level setting error ... Review instructions and cycle tow haul on and off after your done setting prior to restart ...





Mac
 

·
Registered
Joined
·
1,704 Posts
Discussion Starter #5
I followed the instructions exactly 5 times in a row. It obviously worked when I programmed it the first time. Edited by: 1bad01
 

·
Registered
Joined
·
12,262 Posts



I'm sure your doing it correct but a couple things come to mind ...


Perhaps your not getting complete accelerator travel ... Make sure all mats and anything else that might impede the accelerator peddle from reaching full travel ...


Have access to a Tech II or Predator to check Accelerator Pedal Position (APP) ??


Make sure E-brake is on and after selecting desired level, fuel peddle to floor two, three times, back in park, cycle tow haul on off two three times and don't turn key off to start, check confirmation ...


If that doesen't work upgrade to a Attitude integrated with controller ....


Mac
Edited by: Mackin
 

·
Banned
Joined
·
2,530 Posts
Sneaks said:
BzzzztttttttÊ Sorry, Amberjack, the Juice carries it's last setting along for the ride when you remove it.Ê
Yeah the moduel stays programed, but the truck goes back to stock...

Ox
 

·
Registered
Joined
·
939 Posts
I had similar problems resetting my levels. It turned out that I couldn't set my levels with the service engine light on. Try this..start the engine, then turn the key off one click, do not turn it all the way off. Then turn the key back on and try the level set proceedure (the service engine light should not be lit at this point). Many have found this process to allow them to set their levels every time. Hope this helps...


Bob
 

·
Registered
Joined
·
1,956 Posts
I just had my attitude upgraded to ver 1.4i. They put a statement that required agreement by pushing the enter button. Came up every time the truck started for five times. It counted the five agreement "push buttons". The sixth time it quit working.


This will be the third time I have sent this back for either a failure (2x) or a missed upgrade (Alerts and Records). The buttons on this Attitude thing STINK
. First they stick and then they quit ( 2 times).


It is also a pain in the ass to remove every time I go to the Dealer. I do like the performance (when it does work) and all the gauge alternatives (except for the ones that they didn't tell me didn't work for a manny).


I am starting to get pissed about their quality (mis)control.


I guess a will call (since they don't answer e-mails or forum postings) them now and let them know it's coming back again ( I am tired of paying the freight).


BTW, last time it got down to -4*F here the Attitude did not work until the cab warmed up quit a bit. I wonder if anyone in Canada or Alaska has had one of these monitor's freeze to death
wouldn't surprise me.
 

·
Registered
Joined
·
16,610 Posts
LCD display does not work well in the cold. A fact of life. Usually by the time my truck is warm enough that it is comfortbale to drive the attitude display is working.
 

·
Registered
Joined
·
1,704 Posts
Discussion Starter #12
I finally got this thing to adjust power levels again and turns out this whole time (almost a year) I had this thing, it was only on level two!


Man level 4 really kicks @@s!!!!!


Still cant beieve all the drag racing I did with this thing and it wasnt even on the highest setting. My buddy with a 94 Lightning (who tied me in a drag race) wont be happy to hear this.
 

·
Registered
Joined
·
511 Posts
Edge replaced my faulty Juice and Attitude with a brand new box!


........ Then they sent me a bill for $899.00!!!!!!!!!!!!!!



I didnt even respond.


So far, my replacement unit is working fantastic though.
 
1 - 13 of 13 Posts
Top