Diesel Place banner
1 - 7 of 7 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter · #1 ·
Parked the truck in the driveway 10 days ago. Went out to start it and the keyless entry didn't work. Opened the door manally. No courtesty lights, no nothing. Nothing when I turn on the ignition key. Acts like both batteries are totally dead.

Hooked up a battery charger, it acts like the batteries are charged. No lights even with the battery charger hooked up. Any ideas on things to check before I go through the PITA of removing the Edge and call the dealer to have it hauled away?

Truck is an 05 LLY. The only electrical associated mods are the Edge and a Brakesmart brake controller.
 

·
Registered
Joined
·
16,609 Posts
Check to make sure battery cables are tight. Check to make sure your battery charger is working. Connect the charger directly to the battery not the remote hook up.
 

·
Registered
Joined
·
272 Posts
A/C Delco batteries are known for leaking acid around the positive post of the battery. Check that. Also when I was at the dealership we had a lot of escalades come in on the hook that would not start even with the battery charger hooked up. Most of the time it was the battery leaking acid and the cables so corroded from acid that they had a very high ohm load when testing them. Also in a few cases, the body control module and or the onstar module would not go to "sleep" when it was supposed to and drained the batteries to death.
 

·
Registered
Joined
·
631 Posts
One week after I bought my brand new Jeep, It wouldn't start. Nothing would work. Bad Battery from the beginning. Dealer said it was fine but I said no way and they finally gave me a new one. No more problems.
 

·
Registered
Joined
·
1,311 Posts
Mine did that weeks after it was new, I tried jumping it but nothing took. You probably have 2 bad batteries, they will probably replace them under warranty.
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #6 ·
Just to finish the thread:

The culprit was a battery that died a premature death (only 14 months old). The bad battery discharged the second (still OK) battery. The fix was two new batteries.
 

·
Registered
Joined
·
1,460 Posts
was it under warranty or did you have to come out of pocket
 
1 - 7 of 7 Posts
Top