Diesel Place banner
1 - 4 of 4 Posts

·
Registered
Joined
·
903 Posts
Discussion Starter · #1 ·
Me and some buddies went out drivin backroads tonight. When coming to a stop, i looked at my speedo and it was just stuck. When I took off, it began to climb regularly (speedo was stuck at 35 so now when im goin 60, it shows 95.) So now I have no idea how fast im goin except lookin at the tach. This happened about a year and a half ago (truck had around 35K on it). Ive got the 100K mile extended warranty so Im thinkin theyll replace it for free again. Any body else had this problem?
 

·
Registered
Joined
·
30 Posts
My girlfriend's '04 Impala did the same thing this last summer.

Dealer said it was some type of clutch inside the dash.
 

·
Registered
Joined
·
1,785 Posts
Me and some buddies went out drivin backroads tonight. When coming to a stop, i looked at my speedo and it was just stuck. When I took off, it began to climb regularly (speedo was stuck at 35 so now when im goin 60, it shows 95.) So now I have no idea how fast im goin except lookin at the tach. This happened about a year and a half ago (truck had around 35K on it). Ive got the 100K mile extended warranty so Im thinkin theyll replace it for free again. Any body else had this problem?
Luckily I have not, but a buddy of mine has had is replaced twice and "cleaned" twice (his is an 04 6L gasser).
 

·
Registered
Joined
·
700 Posts
It happened to me at 50K and the dealership replaced it via my extended warranty. I have not had any problems with it ever since.

-Wardster
 
1 - 4 of 4 Posts
Top