Diesel Place banner

1 - 2 of 2 Posts

·
Registered
Joined
·
25 Posts
Not sure what my truck was doing today so I came here. Hope someone can explain this.

I was pulling my toyhauler (8,000lbs) south on I5. I had just come to the top of a mild hill, pulled 70mph in 5th for maybe 1.5 miles. Seemed to pull it fairly easy but just after the top of the hill I got slowed down into the low 60ies. Waited for cars to go by in the fast lane then got over to pass. The truck felt like something had grabbed onto the back of it. I had cars coming up so I went full throttle but couldn’t get more than 65mph and it started to cut out. I was turning 2,500 rpm or so and got back into the middle lane to let out of the throttle. It shifted back into high gear and I drove 65mph for the next 20 minutes just fine. Once I was off the freeway everything seemed to be running normal again.

Anyone ever experience anything like that? I got no warning message or code on the DIC or anything. It just started cutting out at 65 and would go no faster. The truck is completely stock with all emissions intact. I was using tow haul and the trans was at 171 degrees. A short while later all was normal.
 

·
Registered
Joined
·
917 Posts
I have a Kodiak, so I dont know if it is any different, but limp mode, will limit your engines rpms, I think it is about 1600/ but dont really remember the exact number. It will allow you to drive the truck, will definitely slow down while towing and going up hill. Down hill and on the flat it might be able to drive okay. It cant be turned off without erasing the code.
 
  • Like
Reactions: E92FF
1 - 2 of 2 Posts
Top