Diesel Place banner

1 - 4 of 4 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
I have had a P0406 (EGR position sensor value high) on this truck since I bought it. Kennedy helped eliminate that, but now it’s time to smog test, in Calihaha.
I replaced the EGR and COOLER BYPASS valves 🤨and still getting the same code 🤬. I cleaned the coolers and didn’t feel replacement was necessary.
Do the these valves need to be “Learned in”? I’ve been told and read that they do. If I do need to, is the dealer the only place to do that?
I have added an an Edge Insight CTS2. I have reset it with this and an EFI device. The code comes right back. I have now entered the 65 mph limp mode. Can anyone shed light on the reset process required when in limp mode? Or is it because the problem is still present?
 

·
Registered
Joined
·
2,617 Posts
Responding to your question about dealer only to do a lean procedure. Any garage or individual that has the capable scan tool equipment can do this, not just manufacturer related dealerships.
I don't know if your new equipment needs the procedure, why the code comes back, or if there are other problems present. .
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
So the end of the story is a broken wire 1” from the EGR valve connector. The insulation was still intact, but the wire was broken clean. The connector was replaced, codes and limp mode are gone. I was able to get it smogged. ALLELUIA!
I did learn the valves go thru a relearn each time this key is turned off. If you listen as you turn the key off, you can hear valves stroking. They don’t need any “relearn” from a device.
Thx for the help. 🤓
 

·
Administrator
Joined
·
16,702 Posts
Glad your issue is resolved.
Thanks for giving us an update!

(y)
 
1 - 4 of 4 Posts
Top