Diesel Place banner
1 - 4 of 4 Posts

·
Registered
Joined
·
192 Posts
Discussion Starter · #1 ·
I purchased an 03 D-Max CC SB 4X4 three weeks ago and am having a hard time getting the dealer to fix an annoying problem. The interior lights come on occasionally and the DIC says that the rear passenger door is ajar. If I open and shut the door it will clear the DIC and the lights go off, but will come back on within five minutes of driving. With the dome over ride engaged the DIC stays clear, but when disengaged it says door ajar and lights turn on. The very annoying part is that the lights will come on in the middle of the night wich sets off the factory alarm.

The truck has been at the dealer for four days now, they say they think it is a bad connector in the harness. Supposedly they have lubed (diaelectic grease) every connector in the harness. The tech told the advisor that he could duplicate the problem on test drives but it would go away before he got back to the shop. I told him they are lying to me, they havent looked at the truck yet because the only way to clear the door ajar message was to open and shut the door. I am frustrated with the experience, any suggestions will be apreciated.
 

·
Registered
Joined
·
16,609 Posts
It's either wiring (not likely), switch or BCM. I woud eliminate this by doing the following:

Disconnect the wiring at the switch. If it doesn't act up anymore, replace the switch.

If it continues to act up disconnect the wire at the bcm (will have to remove pin or cut wire). If it fixes the problem then you have a short in your wire between the door and the BCM.

If it still continues to act up then the BCM is the problem.
 

·
Registered
Joined
·
3,755 Posts
I have had the same problem.....driver side rear door. Happened when we had that big rainny season last year. Thinking water got into the door. My F'n alarm would go off all the time.....cuz it that my door was ajar.
 

·
Registered
Joined
·
192 Posts
Discussion Starter · #4 ·
Well, it appears that they fixed the problem, drove it home tonight and it didnt come on. Before I dropped it off I asked the service wrighter to make sure they had a new latch assembly in stock just in case, didnt want to wait several days for parts. The guy told me WE DONT THROW PARTS AT THINGS, WE DIAGNOSE, well, it WAS the latch that was bad and I DID have to wait 2 days for parts. GRRRRRRR.
To top it off, they didnt get the heavy plastic sound deadener tucked all the way up on the passenger side front door when they put the door panel back on. It looks like a tounge hanging out the bottom of the door. It puzzels me why they had the front door panel off, the rear door had the bad latch.
Damn dealers, good thing the warranty covered the repairs, if had paid a nickel for their work I would have ripped someone a new hole.
 
1 - 4 of 4 Posts
Top