Diesel Place banner
1 - 12 of 12 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
I have a 03 dmax federal lb7 I replaced the HG and 1 new injector because I broke the terminal. In the beginning 2 injectors were reading balance rates of +15 while the rest were reading -7 I continued to drive it because I was running injector cleaner threw it and at the time the rates clears up and went to +2 then I broke down going up hill and they went back to +15 I moved around something in the. Wiring harness on the side of the road and got it to start back up and run right. Then when I got back home I was trying to figure out what happened and I was reading 3 injectors reading +15 I read somewhere that the bail connectors go bad and will mess with the balance rates so last night after I put a new starter in it was running rough then fine I think and now it will idol then kinda surge then die after 15-45 seconds and if I rev it in park it takes forever to rev up I got a code for injectors and a code for frpv low voltage is it my wiring harness?
 

·
Administrator
Joined
·
22,322 Posts
Welcome to DieselPlace

Please list all mods on your LB7
(y)
 

·
Administrator
Joined
·
22,322 Posts
The Duramax wire harness is known for issues.
Inspect every inch of your engine harness for rubbed through wire insulation, rodent damage, corrosion, loose connections, bent pins in the connectors, broken wire, etc
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #6 ·
Is there supposed to be layers and layers and layers of electrical tape then the tubing then more electrical tape after the bail connector
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #7 ·
Wire harness good I’m going to check the grounds I read online that there are 3 on pass and 2 on driver I guess? Would that even be my issue
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #8 ·
Now she runs after outing the wiring harness back on but…. Now I wiggled it and it shut off
 

·
Administrator
Joined
·
22,322 Posts
Now she runs after outing the wiring harness back on but…. Now I wiggled it and it shut off
Short to ground issue within the harness.. Go back through and reinspect
 

·
Registered
1997 GMC K3500 dually 4L80 4x4
Joined
·
64 Posts
I have seen a lot of bad injector connectors, but that wouldn't usually give you a no start. Any idm dtcs? The injectors are on pairs of transformers, one bad circuit kills two injectors. I usually see the harness bad where it bends around the Fuel Injector Driver just before the connector. Good luck.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #11 ·
Your talking about the connector right before the ficim? If that’s how you spell it😂 and does anyone know where to find the grounds I found the 3 on the passenger but none on the driver side where are they located?
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #12 ·
Update runs just surges after I give it gas and when I unplug the big bail connector all the way the balance rates clear up a little
 
1 - 12 of 12 Posts
Top