Diesel Place banner
1 - 11 of 11 Posts

·
Registered
Joined
·
708 Posts
Discussion Starter · #1 · (Edited)
I had my dealer scan my truck to see what the balance rates looked like, and to see if there was any reason for the missing and not so good mileage. He did say that the rates were out of wack, but not enough to where GM would replace any injectors. He basically said that I would have to wait for the truck to quit running before they could do anything. Does that sound right? Here is a look at the page he printed me with balance rates and all of the other info on the truck. Do yall see anything out of the ordinary that needs to be looked at? Could the balance rates cause me to get bad mileage? Thanks a lot for the help. Sorry for it being so small, I don't know how to make it any bigger. If you need it bigger, after clicking on the thumbnail, just go to the bottom right of the page and click on that icon to make it a little bit bigger.
 

Attachments

·
Registered
Joined
·
708 Posts
Discussion Starter · #3 ·
Sorry about that, I was editing the pic.
 

·
Registered
Joined
·
712 Posts
there is nothing wrong with the rates. GM alows from -4 to 4 they all seem normal.
what do u mean by missing? is it only at idle or all the time.
 

·
Registered
Joined
·
708 Posts
Discussion Starter · #5 ·
I notice it especially when going up hills, but it is a sudden surge, and then when sitting at stop lights it will sometimes start to stumble and blow white smoke.
 

·
Registered
Joined
·
5,094 Posts
I thought my truck was missing too. Does it miss at higher RPM's(above 2000rpm)? Does it feel like it is chugging and spit out clouds of grayish blue smoke? If you answered yes to the questions above, you have an EGR popping issue. GM released a reflash on 1-8-06 to address this issue. Have your dealer do the latest reflash (p/n 15904640). They normally do this when these types of issues come up.

Engine OperationPart Number CVN Bulletin # Description 1590464000009F5B- New calibration to address intake pop complaints
 

·
Registered
Joined
·
5,094 Posts
Also make sure your fuel filter is not clogged. I'd change it if you are not sure.
 

·
Registered
Joined
·
708 Posts
Discussion Starter · #8 ·
Thanks a lot. Did the reflash seem to solve the problem?
 

·
Registered
Joined
·
712 Posts
i think bobo is right. sounds like an EGR issue. or fuel filter. the 04 LLY's had issues with there EGRs.
 

·
Registered
Joined
·
708 Posts
Discussion Starter · #10 ·
I just replaced my fuel filter when I did my last oil change about 2 weeks ago.
 

·
Registered
Joined
·
5,094 Posts
The reflash doesn't 100% solve the problem, but it does help a lot. It depends on how severe the problem is to begin with. The most sever cases will see it get better without having the issue solved, while minor popping issues could be completely solved. The reflash is restricting the EGR from 50% to 15% open in some cases with the new reflash. Since the EGR is still opening, the problem can still occur. You could try an EGR blocker plate. That should solve the problem 100%, but I can't find my blocker plate to install and prove this.
 
1 - 11 of 11 Posts
Top