Diesel Place banner
1 - 15 of 15 Posts

·
Registered
Joined
·
1,694 Posts
Discussion Starter · #1 ·
Installed the Banks Turbo Wastegate today, and she makes more boost.

How high is too high?

My gauge needs the high water mark reset, and when it kicked in big time it KICKED IN, but I dont want to blow anything up!
 

·
Registered
Joined
·
13,037 Posts
Very conflicting stories on this subject ...

Heard someone lost a turbo at a mere 32 PSI !!!! Someone else at 40 ... I can PIN my gauge at will 35 PSI !!! Scary to say the least ... I can attest to a TST reading higher then that, electronically I believe !!!!

I would suggest 28 PSI as a max myself anything more is prolly useless without more fuel ... Dont call me if it shatters .... Factory is 22 PSI ....

Mac
Edited by: Mackin
 

·
Registered
Joined
·
704 Posts
I am running the Quad 110hp, and it never goes over 22psi. It doesn't smoke, so will I actually make more power by increasing the boost, or only lower my EGT? I've been thinking of getting the Banks wastegate.
 

·
Registered
Joined
·
1,491 Posts
I'm running the Quad 110 as well and see almost 25psi with the wastegate hose tapped for the gauge.


I get smoke in the 110 setting, but it's more of a gray smoke than black. ?????????? Seemed a bit strange to me.
 

·
Registered
Joined
·
1,237 Posts
I just tried the 110 quad this past week and hit 25-26 quiet frequently. Mind you i had a truck load and towing a decent jag of hunting boats and acces. going through some hills. I have closed my wastegate valve off once completely and did 1 run with the 215quad and the tranny destroyer. I aborted that within 200ft as the needle went past my 35 like nothing and i'm guessing probably went past 40lbs as it bounced of the stop pin
pretty hard. I normally try not to get past 30lbs in normal operation, but went sled pulling or showing the boys what she'll do i try not to go past 35lbs. Haven't blown her up yet, maybe next spring when a bigger turbo gets put on, i'll see what she can handle for how long.
Later Jeremy
 

·
Registered
Joined
·
13,037 Posts
Minn-Kota said:
I'm running the Quad 110 as well and see almost 25psi with the wastegate hose tapped for the gauge.


I get smoke in the 110 setting, but it's more of a gray smoke than black. ?????????? Seemed a bit strange to me.
Strange ??? Nah ,purrrrfect !!!!!!

Mac
 

·
Registered
Joined
·
13,037 Posts
heartbeatcanada said:
I just tried the 110 quad this past week and hit 25-26 quiet frequently. Mind you i had a truck load and towing a decent jag of hunting boats and acces. going through some hills. I have closed my wastegate valve off once completely and did 1 run with the 215quad and the tranny destroyer. I aborted that within 200ft as the needle went past my 35 like nothing and i'm guessing probably went past 40lbs as it bounced of the stop pin
pretty hard. I normally try not to get past 30lbs in normal operation, but went sled pulling or showing the boys what she'll do i try not to go past 35lbs. Haven't blown her up yet, maybe next spring when a bigger turbo gets put on, i'll see what she can handle for how long.
Later Jeremy
I hear ya man ..... Driving by boost is worse then EGT !!!!! I gotta put the gate keeper back on .... =( Every since the tranny has been done it will peg the neddle .... I wonder why ??

Mac
 

·
Registered
Joined
·
83 Posts
FWIW I was getting the same kind of readings with my SPA gauge (32-35lbs.) before I cleaned the connector connections fron sender to cable .Max has been 28.5 lbs. since cleaning.
 

·
Registered
Joined
·
5,934 Posts
When i installed my Banks actuator i was up in the mid 30's too. dialed it back down to 28 PSI max (running hot OJ w/ pred 60HP). the turbo sounded funny once it got up to about 33 or so..
 
1 - 15 of 15 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top