Diesel Place banner

1 - 6 of 6 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
Hi I bought the hot juice with attitude and just want to know if there is a way to make sure I have gotten the hot juice. I am just wondering because there is no mention of "hot" anywhere.

Oh and I installed it today except for the egt which I will do soon and in the first setting I am like this
so I can't wait for the next settings hopefully I won't have to do a tranny anytime soon. I have my Sy that comes first, what good is a tow vehicle if I have nothing to tow
Edited by: Syclone#892
 

·
Vendor
Joined
·
9,678 Posts
Did you sign a release prior to receiving the unit?





Personally, I write hot on them with a marker. If it is sold new as a Hot from Edge, the label may say hot.





Aside from that, the Juicer is the only thing that can verify the program that is installed.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #3
No I did not sign a release. I bought it from a vendor I have bought a lot of syty parts from, he is just getting into the diesel business and he had it drop shipped from edge to me. I think you guys have a policy about listing vendors that has not been approved? If not I will give out his website addy. What is the juicer? I know when it starts it says version 1.something, can't remember exactly what it was would that help?

On a side note I am extremely dissapointed with the juice right now.
I was out shopping today and when I got to the truck and went to start it it cranked then I let off the key when it usually starts but it died. I then tried to start it and it would do nothing, the tach would bounce when I tried to start it and that was all. I unplugged it and it started but I had a check engine light then, I checked the codes one was cam sensor position and I foget the other, cleared the codes and no more light. Hooked the juice back up and it would crank but not start I jingled the connectors for a second and it started right up. I played with it for another 10 minutes and it works fine right now. Anyone ever had this problem, its nothing with plugging in the connectors as I am a mechanic and know how to do things correctly could it be a software problem?
 

·
Registered
Joined
·
1,685 Posts
David,


I had the exact same symptoms with mine. I had a bad unit and Edge replace it for me. I would give them a call and see what they can do for you. These gizmos can and do go bad, just the nature of electronics. Get it swapped and you won't be sorry.
 

·
Registered
Joined
·
420 Posts
When your engine is hot and the juice is active right off the bat (instead of waiting for the correct temperature) I noticed that it would crank a few more turns before starting.

I don't thing that this is your problem however, bad wiring harness seems more like it.

good luck.
 

·
Vendor
Joined
·
9,678 Posts
Std juice now has 125 HP in level 5. Program version # is 4.73





Hot has 145HP in level 5. Program version # is 4.74





Juicer is the programming setup that lodas the Edge programs to the unit. Aside from relying on the sticker on the unit, the Juicer is the only way to tell what program is loaded. Upon connecting to the module, the Juicer will read what the curerent program is and display it. Edited by: Kennedy
 
1 - 6 of 6 Posts
Top