Diesel Place banner
1 - 13 of 13 Posts

· Registered
Joined
·
33 Posts
Discussion Starter · #1 ·
started my truck up this morning...first cold morning of the year...was about -7 celsius, and to my surprise it started as normal, but after about 5 seconds of running the idle jumped up and my exhaust brake was engaged. I thought something was wrong so I shut it down, and restarted and it did the same thing. Got out the manual and apparently my truck has a high idle on real cold starts. Apparently it was working as normal..kinda nice surprise for a change
 

· Registered
Joined
·
346 Posts
I often wondered if one could outfit a 2500HD/3500 with the factory exhaust brake from the C4500/5500 like you have. Both trucks have 3.5 inch pipe correct? I looked at one on a C4500 and it bolts in at the 4 bolt flange on the exhaust. Would be simple to put in but I need air I think.
 

· Registered
Joined
·
93 Posts
Bogie said:
started my truck up this morning...first cold morning of the year...was about -7 celsius, and to my surprise it started as normal, but after about 5 seconds of running the idle jumped up and my exhaust brake was engaged. I thought something was wrong so I shut it down, and restarted and it did the same thing. Got out the manual and apparently my truck has a high idle on real cold starts. Apparently it was working as normal..kinda nice surprise for a change

Bogie


are you getting this stom in Calgary, we are sure getting it here in the Hat.


Cheers


Bear
 

· Registered
Joined
·
1,545 Posts
Is the exhaust brake standard on 4500/5500's?
 

· Registered
Joined
·
1,545 Posts
May need to investigate. I have access to small 12V compressors at work.
 

· Registered
Joined
·
33 Posts
Discussion Starter · #9 ·
are you getting this stom in Calgary, we are sure getting it here in the Hat.


Cheers


Bear


Yes...storm was bad...worst thing was on one of my first stops of I ran over a curb as I was turing into a place (was about 8 inches of snow on road so i didn't see it) and bent the crap outta my rim and knocked the tire off it's bead. No rims this size (19.5 X 6.75) and bolt pattern in Western Canada...no spare either...still trying to decide what to do. They tell me it'll take 3-4 days to bring one in from down east...
 

· Registered
Joined
·
93 Posts
Bogie said:
are you getting this stom in Calgary, we are sure getting it here in the Hat.


Cheers


Bear


Yes...storm was bad...worst thing was on one of my first stops of I ran over a curb as I was turing into a place (was about 8 inches of snow on road so i didn't see it) and bent the crap outta my rim and knocked the tire off it's bead. No rims this size (19.5 X 6.75) and bolt pattern in Western Canada...no spare either...still trying to decide what to do. They tell me it'll take 3-4 days to bring one in from down east...

That sucks. What are you hauling?


Cheers


Bear
 

· Registered
Joined
·
1,545 Posts
Mav, I've got to get one and run it to see the max pressure it will produce. Right now they run on a low pressure system. I should be able to do that next week.
 

· Registered
Joined
·
1,545 Posts
Won't know until next week. I'll get one today but my brother is up for the weekend and we have some serious drinking to do.
I'll let you know as soon as I get it tested.
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top