Diesel Place banner

1 - 20 of 21 Posts

·
Registered
Joined
·
735 Posts
Discussion Starter #1
Just trying to figure out who I get the kit from and how much it is. Also do instructions come with the kit?
 

·
Registered
Joined
·
3,464 Posts
gmdieseltech.com

about $15 after shipping IIRC

no instructions included. instructions can be found in the "Do It Yourself" section of this website.
 

·
Registered
Joined
·
735 Posts
Discussion Starter #6
Yeah sorry, I meant the manual hi idle mod. I bought it from gmdieseltech. Hopefully it's not too hard to do.
 

·
Registered
Joined
·
6,097 Posts
Just take your time and you will be ok. I believe Max Power has a good write up about the installation.
 

·
Registered
Joined
·
3,464 Posts
could never get mine to work.. tried twice...

the problem i ran into was not being able to get the pin to seat all the way, so the ecm never made contact.
 

·
Registered
Joined
·
288 Posts
Can you "manually" force high idle, even if you have the factory high idle option? Wondering.... I have seen the article on how to mod the ECM pin 6 wiring. However, what I've not yet figured out about the mod, is when the wire is pulled from pin 6, and then a new crimped pin with wire is inserted in place, where did the original wire go????? Or is just a pin pulled from position #6? Also, if I already have the high idle option, which I do, and I spliced a switched 12V source to pin 6 will the truck high idle whenever pin 6 is pulled to 12V??? Thanks...
 

·
Registered
Joined
·
3,464 Posts
fiveslo;1560518; said:
Can you "manually" force high idle, even if you have the factory high idle option?
yes

fiveslo;1560518; said:
Wondering.... I have seen the article on how to mod the ECM pin 6 wiring. However, what I've not yet figured out about the mod, is when the wire is pulled from pin 6, and then a new crimped pin with wire is inserted in place, where did the original wire go?????
no wire in there, just a small blue plastic 'plug'

fiveslo;1560518; said:
Or is just a pin pulled from position #6? Also, if I already have the high idle option, which I do, and I spliced a switched 12V source to pin 6 will the truck high idle whenever pin 6 is pulled to 12V??? Thanks...
yes, if you set it up like in the DIY section, it will engage when hit the cruise control 'set' button when it's 'armed'. have to do it twice the first tiime i believe.
 

·
Registered
Joined
·
288 Posts
yes, if you set it up like in the DIY section, it will engage when hit the cruise control 'set' button when it's 'armed'. have to do it twice the first tiime i believe.[/quote]

So by 'armed' its a set and forget thing? Meaning once I go thru the "twice the first time" pushing of 'set' on cruise control, anytime I pull pin 6 high to 12V, the truck will high idle?
 

·
Registered
Joined
·
13 Posts
whenever I pulled the blue plastic plug, a small part of it broke off and I was unable to seat the pin. I had to fish it out with a needle and it worked. possibly might be your problem.
 

·
Registered
Joined
·
3,464 Posts
fiveslo;1561238; said:
So by 'armed' its a set and forget thing? Meaning once I go thru the "twice the first time" pushing of 'set' on cruise control, anytime I pull pin 6 high to 12V, the truck will high idle?

by 'armed' i mean that you set the cruise control switch over so that whenever you hit the button at the end (set) it holds your speed.

i'm pretty sure that's what you do. for more detailed information check out the DIY thread. lots of info on there.


no i don't think that's my problem. it all came out. it's as if there was a little 'gate' in the ecm connector that prevented the pin from seating all the way. i could open it with a paperclip, but chasing it with the pin was a little difficult.

idk, i'll figure it out someday when i have some time and feel like it.
 

·
Registered
Joined
·
1,366 Posts
I believe the wire must be 22ga, any larger and it makes contact with the connector and prevents the pin from locking into position. Make sure there are no burrs at the crimp or solder joint, if not, try trimming the insulation.
 

·
Registered
Joined
·
3,464 Posts
done it all. both times the kits were from merchant. i always end up bending the wire where it meets the pin, or destroying the pin itself.
 

·
Registered
Joined
·
219 Posts
nosliw;1564814; said:
done it all. both times the kits were from merchant. i always end up bending the wire where it meets the pin, or destroying the pin itself.
Same problem. Looking into a kit from BD Diesel.
 

·
Registered
Joined
·
2,033 Posts
I thought I remembered reading that there were different sized pin connectors for different ECM's...like for LB7's and LLY's

PM Max Power, he can help
 

·
Registered
Joined
·
3,464 Posts
sparkyss;1566271; said:
Same problem. Looking into a kit from BD Diesel.

let me know how that works out.


and there are differences between LLY and LB7 pins. i ordered the kit from merchant for the LLY.
 

·
Registered
Joined
·
219 Posts
Just an update. The kit from BD Diesel is the same thing you can get from Merchant, just more expensive. It looks like this is the only way to get the high idle to work. Maybe I'll try boring out the top of the connector to accommodate the wire. I'll keep ya' posted.
 

·
Registered
Joined
·
2,099 Posts
lly,lb7 and lbz are all different pins
try using a small dab of die-electric grease
if you just bought the pin from gm like i did make sure you use a small gauge wire to big it wont fit and cutting back the insulation makes it harder to insert because it bends the wire
 
1 - 20 of 21 Posts
Top