Diesel Place banner

1 - 18 of 18 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hopefully someone here can make this easy for me. I have an 84 k10 6.2 w banks. Just got the truck, it started and ran for a few days, then it wouldn't start, cranking fine. Find the bulkhead connector is melted. Got another one from junkyard, wired it in.

The glow plugs are on a momentary switch it the cab, the light in cab comes on and solenoid makes noise and I have voltage at glows, figure that's working, even though the white wire on the controller goes nowhere.. Ok so that's one issue, there is no white smoke coming out when cranking, so I assume not getting fuel. I checked the pink wire at injector pump, it has power when key on and during cranking. I opened the fuel air bleed while cranking and got nothing out of it, I added fuel to tank, got fuel to come out steady no bubbles. Next thing I'm going to remove glows and crank it some more. What I need to know is, is there a shut off or ground that could be hooked up wrong? Or is it as basic as if I have power at pink wire it should fire? I do hear a slight click when unplugging and reconnecting pink wire, but it's not very loud. Thanks..
 

·
Ex- 6BT Square Body Man
Joined
·
9,736 Posts
What I need to know is, is there a shut off or ground that could be hooked up wrong? Or is it as basic as if I have power at pink wire it should fire? I do hear a slight click when unplugging and reconnecting pink wire, but it's not very loud. Thanks..
If you hear the solenoid clicking then it should run.
If it was run out of fuel then it will take a while to get the air purged out.
When you try to start it do you see any air bubbles in the clear line?
 

·
Let's take the Truck!
Joined
·
5,643 Posts
Shut off solenoid is a quiet click noise. You think the lift pump is bad?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #5
Thanks, I'll keep trying to purge the air.. There are a few don't bubbles in the return line. I don't think it's the lift pump as I get fuel out of the bleeder when cranking while pink wiree is disconnected.
 

·
Ex- 6BT Square Body Man
Joined
·
9,736 Posts
Pull a couple glows and see if you get misting out of the holes.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #8
No misting, pulled an injector line, it's dry.. So its likely the injector pump? I'm just worried is a wiring issue, can anyone confirm the pink wire is all that matters, and its hot..
 

·
R.I.P. Sam
Joined
·
32,078 Posts
No misting, pulled an injector line, it's dry.. So its likely the injector pump? I'm just worried is a wiring issue, can anyone confirm the pink wire is all that matters, and its hot..
It was already answered here, the clicking, then elaborated by JC.

If you hear the solenoid clicking then it should run.
If it was run out of fuel then it will take a while to get the air purged out.
When you try to start it do you see any air bubbles in the clear line?
I opened the fuel air bleed while cranking and got nothing out of it, I added fuel to tank, got fuel to come out steady no bubbles. ..
As Legendman figured, this signifies the system may have run dry and has air in it. It may take a bit to purge.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #10
Thanks a lot, what is awhile to purge? I have cranked it for 10 second or more atleast 20 times. I pulled the line going to one of the injectors and it was dry while cranking..
 

·
Registered
Joined
·
6,168 Posts
Pull all the GP's and unplug the green wire from the IP, undo all the injector lines a turn.

Now crank till fuel is dribbling from each injector line, do them up.

Now crank again till there is a fog of fuel from each cylinder, re install the GP's and the green wire to the IP, cycle the GP's and it'll fire... run rough... and fart and .... but it'll run and clear it's self.
 

·
Premium Member
Joined
·
1,299 Posts
Pull all the GP's and unplug the green wire from the IP, undo all the injector lines a turn.

Now crank till fuel is dribbling from each injector line, do them up.

Now crank again till there is a fog of fuel from each cylinder, re install the GP's and the green wire to the IP, cycle the GP's and it'll fire... run rough... and fart and .... but it'll run and clear it's self.

Hah. Maybe this should just be an auto-reply to every topic.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #13
Went out today, Truck started right up.. Must have bled enough of the air out yesterday. Thanks a lot for all the help, without you comments I would have been chasing my tail and probably still looking for the electrical issue that's not there..
 

·
Registered
Joined
·
1,647 Posts
Late to this party, but glad to hear she's running again.

Tons of knowledge on this forum. More then any M1028 could haul.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #15
Damm luck anyways.. So drove it the last two days no issue other than left tank reads only full, I put 15gal in it, drove less than 30 miles, come out after driving it earlier, won't start, no white smoke, fuel at filter.. I switched back to the other tank that seems to read the level, I'm going to put some more fuel in it and try and get it started again.. When do I start suspecting a bad IP?
 

·
R.I.P. Sam
Joined
·
32,078 Posts
. When do I start suspecting a bad IP?
When it wont start hot but will start cold, or when you pour some cold water on the IP to cool it off. Sign of head rotor wear and expanding tolerances when hot.

Other signs are usually smoky hazy idle, which can also point to injectors.

Every time a tank runs out, it usually fills the filters with crude and garbage from years of condensation and use. I proper fuel gauge is important when your having issues like this, so you can take that issue out of the picture.

I guess I better fix mine. :hole:
 

·
Registered
Joined
·
10 Posts
Discussion Starter #17
I ordered a new head and Rotor assembly.. Will I be able to put it on with injector pump in the motor or will I have to remove the pump? Thanks
 

·
Registered
Joined
·
6,168 Posts
I wouldn't try and replace the H&R on the engine as it has to absolutely dead clean, 1 kibble.... and it's hooped.
 
1 - 18 of 18 Posts
Top