Diesel Place banner

1 - 8 of 8 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
I have a 2005 Duramax with a 5" Silverline cat delete down pipe back exhaust, AFE Cold Air Intake, and a Edge w/ attitude

The other night headed home.. the check engine light came on, Lost all power, the engine sounds very rough, and it was pouring white smoke...

The truck was in power level 1 on the edge, and we were just driving. Not getting on it or anything.. Any Ideas?

When you remove the edge the truck with drive and Shift really hard.. but it still has a loss of power. and sounds very weird

When we got to the dealership the truck had 8 trouble codes.. we cleared them twice and it showed 2 for injectors.. .
 

·
Premium Member
Joined
·
20,561 Posts
check the fuel injector/FICM harnesses first. Theres a TSB out on them.
 

·
Premium Member
Joined
·
20,561 Posts
can you get the exact DTC's from the dealer? The 4 digit code...one of the techs here could help you out there...

I still wonder if its the wiring harness...usually when injectors fail they start to slowly get bad balance rates, high return rates, not fail all at once like in your situation.

Any "U" codes or just "P" codes?
 

·
Registered
Joined
·
200 Posts
Could it be that one of the intercooler line couplings blew off? Heard of similar results when this happens... My 2 cents...
 

·
Registered
Joined
·
412 Posts
Could it be that one of the intercooler line couplings blew off? Heard of similar results when this happens... My 2 cents...
Check that, but it sounds like the common No. 2/7 injector wire problem. Do a quick search on that and you will find it. Could be a bad injector though. Post your codes.....

Also, complete your signature and you will get more complete and relavent info! Take care.....:)
 

·
Registered
Joined
·
1,870 Posts
Dude that exact thing happened to me, and it was the Inj. wiring haraness.
 
1 - 8 of 8 Posts
Top