Diesel Place banner
1 - 20 of 36 Posts

·
Registered
95 chevy k1500 silverado
Joined
·
36 Posts
Discussion Starter · #1 ·
New here but have had 6.5s for a while now. I've done research but am at loss.

I have a 1995 k1500 6.5
Situation started With erattic idle and then hard start when hot. So I just replaced my 5288 injection pump with a reman 5521 from Pensacola fuel injection. After purging air I finally got the truck to start and idle . The problem now is I have throttle response when in park or neutral but once in any gear there is absolutely zero throttle response. From what I have researched I should have no issue with my current prom (BXRD 1624 4850) when switching my 5288 pump to the reman 5521. Is this correct?

The codes pulled are as follows

DTC 35 - Injection Pulse Width Error (Time Short) -PMD or Injection Pump fault
DTC 19 - Crankshaft Position Reference Error


I will add that I have a brand new pmd from Leroy diesel with a 9 resistor

Any help would be appreciated
Thank you
 

·
Registered
95 chevy k1500 silverado
Joined
·
36 Posts
Discussion Starter · #2 ·
1. Describe the problem you are having in detail: No throttle response after injection pump install

2. Year of truck/engine.
1995
3. Odometer reading (indicate miles or kilometers). 273xxx

4. Indicate the model number on the Injection pump (starts DS4 or DB2......). Ds4 5528 was old pump new reman is 5521

5. Indicate if you know if it’s a 1500, 2500, 2500HD, 3500, 3500HD. 1500

6. Do you have an EGR on the engine? (An F or an S engine code 8th VIN digit) Had egr but swaped intake to non and deleted vac system
7. Air Filter condition (visual check). Clean/new

8. Fuel filter condition (freshly changed, mileage since changed). new

9. Location of PMD/FSD? (ex. on pump/remote over intake, behind bumper). new pmd behind front bumper

9a. If remote mounted, describe wiring harness (homemade or purchased from which vendor). harness and pmd from leroy diesel

9b. Indicate the location and condition of the FSD/IP grounding wire. stock location on Ip

10. Outside Temperature (C or F). _ ° 75


11. Service Engine Light while running?- on/off/intermittent. on dtc 19 and dtc 35

11a. Service Engine light does glow during start/cranking/bulb check: Yes/No yes

12.Have you scanned for engine codes? Yes/No yes

12a. List exact results on engine codes. Dtc 19 dtc 35

13. Condition of Battery terminals (removed, cleaned and tightened).
Clean and tight

14. Known condition and age of Batteries.
New

14a. Are batteries a matched set of same age?yes

15. Condition of Major Grounds (removed, cleaned and tightened) grounds good

15a Have the batteries been individually load tested?
No
16. Does engine crank, or "turn over"?
Yes
16a. Does engine start and run?
Yes with fethering throttle

17. If engine does not start- Crack injector line: do you have fuel? Yes/No
18. Does your Wait To Start light come on?
Yes

18a.Number of seconds WTS light is lit.
8 to 10

19. Engine Cranking speed (if you have an accurate tachometer).
Normal with full charge

20. Are you experiencing Stalling?
Sometimes
20a. Describe the event (upon startup only, down the road, hit a bump, etc...)
Sometimes on startup after new ip

20b. Do you notice loss of dash or instruments?
No
21. Check turbo inlet and air filter for obstructions.
No obstructions

22. In a no-hot start, pour a bottle of room-temp water on the injection pump. Does it start now?
Old pump did

23. Lift pump test - Describe results.
Lift pump in working condition

24. Upon cold start, does the radiator hose get hard quickly? Yes/No
No
25. Upon cold start, do you have excessive white smoke? Yes/No
No

26. Do you have excessive cranking time before the engine starts? Yes/No
Yes

27. Have you used the block heater? Does it affect engine starting? (only try for starting problems).
Not used yet
28. Are all glow plugs in proper working order?
Yes
29. During hard acceleration, do you have excessive black smoke? Yes/No
Unknown haven't benable to drive
30. Do you have any unusual exhaust smoke issues?
No

31. Turbo check out - Pass/Fail

32. Indicate fuel that you are using: Bio-Diesel, #2 Diesel, SVO/WVO, other
32a. If running Veggie Oil fuel setup, indicate details of your conversion (homemade or packaged system).
33. Are you using any fuel additives? If so, please list.
34. Upon unscrewing fuel cap, do you have a large vacuum formed in the tank? Yes/No
No
35. Do you have any service history available that might pertain to the problem you are having?
No

36. Please indicate any modifications to the vehicle that might help us diagnose

Engine re ringed at 273xxx miles
New rings
New connecting rod bearrings
New head gaskets
New rear main
Head studs
new reman injection pump from Pensacola fuel injection

Flopro 3in down pipe to 4in and 2.5 in crossover
Aftermarket intake
Manual waste gate
FTB MOD
Pmd relocate
Boost,EGT, fuel pressure gauges
Dual thermostats and ho water pump
High idle switch
Pt wiring solutions hd lift pump
Leroy diesel lift pump harness
 

·
Registered
95 chevy k1500 silverado
Joined
·
36 Posts
Discussion Starter · #4 ·
OkDually I have a new crank sensor on order. Im not hopeful that that's the issue the symptoms are the same with the existing sensor plugged in or un plugged. But hey I could be wrong I won't know till Tuesday when it gets here!
 

·
Registered
95 chevy k1500 silverado
Joined
·
36 Posts
Discussion Starter · #6 ·
DieselPro that's exactly my fear ....I have a felling I will be returning my purchase rather than sending my core.
Any suggestions on reputable places for a pump?
 

·
Registered
95 chevy k1500 silverado
Joined
·
36 Posts
Discussion Starter · #8 ·
Try accurate diesel in Michigan.Tim is great to deal with.Great customer service👍
Thank you! I was just on their website. I've had great experience with them before but kind of forgot about them. Hopefully I can return the probably faulty pump without issue and see if they can hook me up. Unless somehow I figure out some other issue.
 

·
Registered
95 chevy k1500 silverado
Joined
·
36 Posts
Discussion Starter · #11 ·
No problem.The service at accurate diesel is superb.Could not ask for any better.I have installed a reman 5521 pump from Pensacola diesel before some 15 yrs ago and didn’t have any issue with it.
I've bought Injectors from Pensacola multiple times with no issues. I'm just at a loss with this pump. Everything before the pump was changed worked fine other than the occasional surge and erattic idle and the no/hard start when hot.

Another question I have now would be will the engine run with the optical sensor unplugged? From what I understand is that either the crank sensor or optical sensor at least one has to be working for the pump to work right. Ive read that with the optical sensor unplugged it will simply go into limp mode. I ask this because when I unplugged the crank sensor the truck will run and idle as long as I hold the throttle around 800 to 1000. Crank sensor plugged back in the engine will idle on its own now ...but when I unplugged the optical sensor the engine dies.
 

·
Registered
95 chevy k1500 silverado
Joined
·
36 Posts
Discussion Starter · #13 ·
Unplugging the optical is supposed to put the engine in limp mode and your right,one of the sensors has to function properly.Dieselpro is most likely right about the pump being the culprit.
That's what I though. I'm thinking it's the pump too! I'm going to change the crank sensor just to say I did then deal with trying to return the pump we will see how that goes.
 

·
Registered
95 chevy k1500 silverado
Joined
·
36 Posts
Discussion Starter · #22 ·
If you unplugged the OS. With the CPS plugged in, and the engine died. That along with the code usually means the CPS is bad. I would replace it before pulling the IP and sending it back.
Bad idle, and problems starting are symptoms of bad CPS. Also After installing new one it is best to do a relearn if possible.
Thanks for the info. The new sensor should be here Tuesday and fingers are crossed! If that is the issue, Does the relearn require a scanner or is there another way?
 

·
Registered
95 chevy k1500 silverado
Joined
·
36 Posts
Discussion Starter · #26 ·
So just an update. The guys from Quadstar got back with me and said the my 5288 and 5521 aren't interchangeable. He said my truck should of never had a 5288.

But right now I've got a different problem as in like [COLOR=rgb(49, 130, 233)][B][SIZE=4]dieselolds[/SIZE][/B][/COLOR] said the cps can be difficult to remove...mine was. Well still is rather I'm currently in the process of pulling the timing cover to get the old one out.
So we will see when I get off work today if I can get it out.
 

·
Registered
95 chevy k1500 silverado
Joined
·
36 Posts
Discussion Starter · #29 ·
The CPS needs to be butchered to get out.
Most of the time it will crumple as you try to pry it out.
Then you need a strong somewhat longer flathead and found a fulcrum point to pry it out.

It took me 3 days.
I had to take out the alternator, removed the bolt to P/S pump and set it aside (keep the hoses connected) so I can have a clear view of the sensor.
Then I tried to pull the cable and it crumpled.
Drill the part, still does not move but it breaks a chunk of it where I can put a flat blade screwdriver to pry it out. (on 3rd days).
Yeah I tried for about 5 hrs and finally just gave up. I need to replace my front main anyways and also this will give me an excuse to Check the timing chain. I should have it out today after work but my new gaskets won't get here till Thursday.
 

·
Registered
95 chevy k1500 silverado
Joined
·
36 Posts
Discussion Starter · #31 ·
Here is the IP application chart to show info on the 5288 and 5521 pump and model year it went to on pg 4 and pg 5
https://www.dieselplace.com/forum/a...s-master-list-information-6-5-answers-119.pdf

Removal tips for the CPS: Replacing the crankshaft position sensor
Thank you!
I tried the flat bar trick on the cps with no luck as my screws kept striping out ....other than I haven't tried to pull the power steering pump to get better acess yet ....I found some longer screws today that I might try before I completely pull the timing cover. I will probably try moving the power steering pump and giving it one more go before I completely give in.

Thanks for info again!!
 

·
Registered
95 chevy k1500 silverado
Joined
·
36 Posts
Discussion Starter · #33 ·
Incase anyone was curious here is the new sensor compared to what's left of the old!!!

Timing cover ended up coming off and after very careful 20 minutes with a hammer and punch it finally came out .....and the cover is still intact. Now is just the tedious process of old gasket removal.



Automotive tire Bumper Gas Rim Cylinder
 

·
Registered
95 chevy k1500 silverado
Joined
·
36 Posts
Discussion Starter · #36 ·
Quadstar is not all the hype you think he is.... 5288 was superseded by the 5521 which is the basic standard for quite some years. If it don't run right get rid of it. But a good 5288 will run as good as a 5521. No reputable dealer would build one to 5288 specs as newer improved parts are in the 5521.
That's kinda what I gathered from the chart that OkDually shared was that there should be no issues between the two pumps. Now that I finally can get the new sensor in I'll see what happens when it's all back together and go from there I guess.
 

·
Registered
95 chevy k1500 silverado
Joined
·
36 Posts
Discussion Starter · #37 ·
Well i got everything back together. Now the truck is very hard starting and when it does start it usually dies right away. I was able to get it to idle but it was white smoke like crazy out the tail pipe. Is my timing off? Is the pump junk? Any one have any ideas?

Also I know some one mentioned the koko procedure. Will that work on obd1?
 

·
Registered
95 chevy k1500 silverado
Joined
·
36 Posts
Discussion Starter · #42 ·
The optical sensor. (The jumper wire with the noise reducer in it) 1 end plugs into the engine harness and the other end plugs into the optical sensor. Take that section out and plug the engine harness directly into the optical sensor. Both times I had this issue I had the same codes and the same problems
Thanks for the tip I will try that tomorrow and see what happens. I was curious as to what that little jumper was for
 
1 - 20 of 36 Posts
Top