Diesel Place banner
1 - 6 of 6 Posts

·
Registered
Joined
·
84 Posts
Discussion Starter · #1 ·
I have a 97 Suburban with the 6.5 in it. Today while running down the highway the water in fuel light came on and then the truck fell on its face and will barely run what is wrong with it and how do I fix it? My scanner says its an injection pump metering control A, but on here it says P0251 Injection Pump Cam System. Is my pump dead?
 

·
Registered
Joined
·
888 Posts
Sorry if this is a dumb question, but have you checked to see if there is any water in the fuel?
If you have much (any?) change the fuel filter or you'll still have water in the fuel.
 

·
Registered
Joined
·
84 Posts
Discussion Starter · #3 ·
Changed the filter twice but still wont run. Its camming really bad right now like a small block with a big cam. I bled the lines and nothing. It barely wants to start and you have to hold it to the floor for it to fire. To the floor it will only pull 2800rpms very slowly. I'm loaded with a tractor on the trailer sitting at the library.
 

·
Registered
1995 GMC Suburban
Joined
·
18,454 Posts
For basic testing, DO the diagnostic checklist to eliminate cheap stuff first.
 

·
Registered
1995 GMC Suburban
Joined
·
18,454 Posts
From my experience reading, that points to a dying IP.

You may want to PM a member called DieselPro. He is the IP expert here.

The Diagnostic checklist just making sure that you have eliminated cheap stuff before changing the IP. There are things to pay particular attention such as LP and OPS. If the IP does not get enough fuel from the tank pump by LP, it can throw a code also. At the same time, the IP may be dying because the LP goes out, etc. PMD is always a culprit, although most of the time when PMD gives up, it may not give any code.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top