Diesel Place banner

1 - 16 of 16 Posts

·
Registered
Joined
·
1,715 Posts
Discussion Starter #1
if it Dont get edited or deleted here go's

how many who HAVE THE EXTREME HAVE HAD THERE INJECTORS REPLACED OR HAVE A INJECTOR CUP SEAL PROBLEM
 

·
Registered
Joined
·
12,262 Posts
Would that be post 01/02/03? Saying that GM recognized a issue with flawed injectors.


Mine were replaced,only had one that was knocking.I had good primary fuel filtering too.
 

·
Registered
Joined
·
4,755 Posts
Dave good to see you post again. Just figured you were too busy with all that work down south to come visit anymore.
 

·
Registered
Joined
·
1,715 Posts
Discussion Starter #4
Im losing some coolant and it seems to be more prevalent when Im on the big setting..........not much...but some neverless.. and I ve had the water pump changed and a couple of suspect heater hoses............not trying to point a wicked finger but I knew mack had a leak and I thought trippin was loosing some coolant too.................70 + hours a week ....had a real good first year now the pressure is on to repeat and have another and better the first
 

·
Registered
Joined
·
12,262 Posts
My leak I had was the turbo coolant line.

Running pane on this one too?
 

·
Vendor
Joined
·
9,676 Posts
Those turbo coolant hoses that Juice and Company were replacing is the first place I would look. Also, the aluminum heater tube where the stay bracket welds appears to be another potential for a micro leak.
 

·
Registered
Joined
·
4,755 Posts
The higher the HP goes the more thing will break that's for sure. I would look to see if there is coolant in the oil or not. Also one way to see if it's in the cylinders would be to remove the glow plugs and let it sit overnight. In the morning have a few friends stand on either side of the engine and watch for water/antifreeze when you spin the motor over with the glow plugs out. If you find something I would look at the injector cups first as that seems to be where most of the problem are found.
 

·
Registered
Joined
·
1,715 Posts
Discussion Starter #9
oil is fine..............turbo and heater hose are the new suspect.........have seen some vaoprs on morning starts.........think there just condensation................. no pane
 

·
Registered
Joined
·
6,210 Posts
I've replaced two water pumps for leaking coolant.

The injectors were warranteed due to bad balance rates at 40,000 by the dealer, it has been using coolant ever since. Sent it in yesterday and dealer has confirmed that the injector cups are leaking.

I should have it back tomorrow.
 

·
Registered
Joined
·
11,955 Posts
Injectors replaced at 37000 IIRC and had the Xtreme for part of that time. Ran fine till 55k on the Xtreme driven daily till I put it on its lid. :(
 

·
Registered
Joined
·
11,955 Posts

·
Registered
Joined
·
6,995 Posts
Phil it doesn't count since your new truck is faster than the old one ):h
 

·
Registered
Joined
·
4,643 Posts
his new truck WILL BE faster than the old ever was!
 
1 - 16 of 16 Posts
Top