Diesel Place banner

1 - 3 of 3 Posts

·
Registered
Joined
·
160 Posts
Discussion Starter #1
Picked up my '05 reg cab srw lb 3500 from the dealership back in July. Love the truck, I mean love the truc. Put it in 4 wheel drive 2 days after I picked it up and noticed a little noise in the drivetrain. Seemed somewhat acceptable stepping out of a lifted '85 K3500 w/ a mild 400ci and 38's, I mean come on, diff noise is normal w/ that much weight and power pushin' you through 3-4 feet of mud. But after 4-5 snow storms and plowing, it got LOUD. Took it to the dealership I got it from, and my buddy who is master tech there told me he has seen everything from Escalades to 4x4 C5500's come through with either too much bearing preload or not enough, even no fluid in the front diff. What's up? I am in no means doubting GM in the least, because 2 buddies of mine have '05 super dookies and they were both without their truck for 3-4 weeeks beacause of the rear main seal blowing out of them. I race GM, have always owned GM, have powered non gm vehicles w/GM mills and have never dealt with some of the weird shyte I have with this truck. Granted it was all little easy stuff, but still. I am just glad I will only be without my truck for an afternoon while the Clutch fan, EGR valve, fuel shraeder valve and front diff get replaced!!! Anyone have anything similar they noticed? P.S. G.M. agreed to replace the WHOLE axle under warranty.
 

·
Registered
Joined
·
826 Posts
I guess I should check my 4WD out. Had the truck 2 months and 4K miles and have not even thought about it. I guess I better read my book.
 

·
Registered
Joined
·
329 Posts
my rear axle was about 2 qts low when I changed it at 5k... luckily i hadn't towed much during that time...
 
1 - 3 of 3 Posts
Top