Diesel Place banner

1 - 6 of 6 Posts

·
Registered
Joined
·
434 Posts
Discussion Starter #1
I've done a search & read a lot of post but can't find one that covers my problem. While looking for the correct tie-in connection in the box below the dash (just left of the brake pedal) I must have shorted something out. I was working with my meter & trying to determine which connector would function with dimmer switch on dashboard lights my dashboard lights went out! I had my head lamps on at the time and they stayed on. Then I noticed my radio lights/clock not working! So I worked the dimmer switch up & down and get nothing - BUT - when I roll the dimmer switch up all the way into the notch position where all the interior lights come on the dash lights come on as well as the led in the radio! What the hell! I've been on a fuse hunt for over an hour - left side of dash board - under the hood in the main box - nothing! Is it possible I've blown a relay or what ever there called in the box under the dash? There's 2 gray colored ones next to where I'm working but I was checking the contacts in the lower right corner of the box as suggested by many for plugging in pod gauge lights. Anyone know a cure?
 

·
Registered
Joined
·
3,291 Posts
Check your ILLUM Fuse 10A, located in Fuse Block - Left of Instrument Panel.
Reference 2002 Helms page 8-331

I tapped my gauges into wire on the back of dimmer switch. Can't remember what color, might be PPL/WHT. It's been talked about on this forum. You can find it with your test light.
 

·
Registered
Joined
·
434 Posts
Discussion Starter #3
I've checked that fuse as well as almost every other fuse. It's gonna be a bad switch or some type of relay. Just don't know how to pin-point the bad part.
 

·
Registered
Joined
·
1,549 Posts
I tapped my gauges into wire on the back of dimmer switch. Can't remember what color, might be PPL/WHT. It's been talked about on this forum. You can find it with your test light.
Just tapped the dimmer switch wire on my 05 today. It's brown with white trace.
 

·
Registered
Joined
·
434 Posts
Discussion Starter #5
I'm still at a loss of what going on with my dash board lights - I guess I'll have to go see the GM boys in the morning. Anybody else have an idea? Anyone ever have this same problems?
 

·
Registered
Joined
·
434 Posts
Discussion Starter #6
Problem solved

I took my truck to the Chevy dealer/shop as much as I hated to. It was the gauge light dimmer switch that was bad. After waiting about 1 1/2 hours just to get the truck in the shop it only took 20 minutes to diagnose the problem & about 15 minutes to replace it. $130 later all is working good. Just thought I'd post my results in case someone else happens to have the same problem. It's hard to believe I shorted it out while looking for a tie-in point for my pillar gauges - you'd think the fuse would blow before the switch was damaged. Still scratching my head on that.
 
1 - 6 of 6 Posts
Top