Diesel Place banner

1 - 14 of 14 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
2004 LLY Allison, Cab and Chasis w/dual fuel tanks, 500 miles


The fuel gauge quits working at random. Go to the dealer they reset all the codes and it starts working again. Talked to GM on the phone and they said they have had several do this and at this time the problem is unresovled. The only thing that I have noticed that brings this problem on is that leave the truck idling for 15 minutes or so, and when you get back in the fuel gauge is below empty with the warning light on.


Thanks for the help,


DRS
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
Update:


Driving along, engine died, wouldn't restart. Added fuel to both tanks (should have been around half full), bled system just incase and it still wouldn't start. Any ideas?


DRS
 

·
Registered
Joined
·
11 Posts
My 04 LLY x cab and chassis does the same thing. The tricky part is that once the gauge trips to empty, it shuts off the transfer pump between the front and rear tank. If you dont know this and estimate ileage by the trip meter, you will run out. I fill up every 200 miles.Truck has 2000 miles on it, and the gauge has tripped 3 times so far. The last time, it idled for 10 secs, and then triped to empty. I have spoken to several cab and chassis owners, and they all have the same problem, gas and diesels. I am very disappointed with this issue, would hate to have to see GM buy it back for a fuel gauge issue.


Dino
 

·
Registered
Joined
·
10 Posts
Discussion Starter #5
We replaced the fuel transfer pump and the fuel pump/sensor in the front tank and everything works fine now. The transfer pump was running but not pumping.





DRS
 

·
Registered
Joined
·
10 Posts
Discussion Starter #6
update:


left idling with the doors open and the fuel gauge tripped to empty with both tanks full.





any ideas
 

·
Registered
Joined
·
10 Posts
Discussion Starter #7
Reset codes, worked for one week then tripped to empty. Showed between a 1/4 and 1/2 on fuel gauge when it quit working, pulled the rear tank "completely empty"


Help someone?


Thanks,


DRS
 

·
Registered
Joined
·
3,193 Posts
I have a 2001 3500 cab and chassis w/ the 8.1 and had the same problem. The first time it happened(don't remember the mileage) the dealer replaced the front take gasket seal. It was corroded. The second time it happend, out of warranty, they had to replace the sending unit and fuel pump. Extremely expensive job. The truck was too heavy for lifts(weighs in @11,500#s). They had to drop the drive shaft, drop the tank , then perform the work. They quoted me almost $800.00
. I bitched about the price and they called me back(1/2 hour later) and said it would cost $625.00. Sure hope this isn't a continual problem for future owners.
 

·
Registered
Joined
·
397 Posts
I just had a 4200 mile flawless driving vacation while pulling an 8000lb fifth wheel.


2nd day back to work and my fuel guage just did the same thing. I cranked the truck, went back inside to get my radio and a drink, came back out and the guage is on empty with the warning light on. I knew the tank was almost full, so I put the truck in gear and started to work. The instant the gear selector came out of "P" the guage went to full and out went the warning light.


MY QUESTION IS, CAN A FAULTY SIGNAL FROM THE GUAGE SHUT DOWN THE ENGINE?


Doug.
 

·
Registered
Joined
·
227 Posts
I have a customer here with three of the cab/chassis trucks.
Every one of them does this. The newest 04 truck did it at 600miles. I have fixed two of his trucks now to eliminate the crappy transfer pump setup. The engineer should be shot over this one. Anybody who mounts a pump above the top of the tanks (same pump they used on 6.5L, that failed regularly), has no filter in line to protect it is an idiot.
I will try to have pictures up on my site , probably next week, of how to fix the transfer pump problem for good. Still working on the fuel guage fix. But with my fix you will not run one tank dry and have a full tank in the other one.
Brian A.
 

·
Registered
Joined
·
214 Posts
Well My 05 has been in 18 times! for this same problem!, changed sensors, transfer pump,sending units and now they want to change the pcm. THIS SUCKS!
 
1 - 14 of 14 Posts
Top