Diesel Place banner

1 - 8 of 8 Posts

·
Registered
Joined
·
63 Posts
Discussion Starter #1
Hey guys,

My wife is a very active barrel racer in all the western states so everyweekend is spent driving to and from places, are trailer is a 4 horse living quarters brute.I've been off and on this sight for two years trying pickup a little knowledge here and there about how to get the best performance out of my truck. Let me say there is some very intelligent people giving some great opinions and fixes for trucks!!! with that said, I have the 04.5 LLY motor in a dually, I've had the speedo repaired and the brake system gliche repaired. The overheating problem is really a problem that I've all but given up on, so I'm not even going to try. My problem is the engine fan It seems to run at really odd times, it runs constant when it's 10 degrees or 95 (very annoying) I know that this has been addressed in the forums before and I never really got the opinion of most of you to fix or maybe approach the dealer in a different manner maybe to get this fixed. I've had many things replaced and still get the same results,(fan hub, sensors the works) I'm somewhat knowledgable about the components that make up the cooling system but am struggling here. Any input good bad or silly would be appreciated. Thanks guys!!!:ro) :help:
 

·
Registered
Joined
·
367 Posts
Hey juiccer, are you in Yuma this weekend for the Rodeo?

What about Scottsdale the first weekend in March?

We'll be doing the Scoreboard and Sound in Scottsdale.
 

·
Registered
Joined
·
63 Posts
Discussion Starter #3
wow, my wife is one her way back from Yuma as I posted this thats strange she ran earlier today in slack. she was I think 34 out thats strange that you would ask.
 

·
Registered
Joined
·
367 Posts
If you come to Scottsdale, look me up. I'll be up in the announcer's stand with the computer equipment.

PM me with the wife's name.
 

·
Registered
Joined
·
63 Posts
Discussion Starter #6
txchristopher is this a prominent problem with all the engines in the llys or is it just a few? GM thinks I'm crazy I've talked to techs representatives basically anybodys ear I could chew off I have and haven't got anywhere! My god the thing runs at all temps shutting off once in awhile, it seems that if on flat ground when it's running nonstop if I pushin the overdrive lockout and let the motor rev high it shuts off, but as soon as I let it go back to overdrive it turns back on. I know that has very little to do with it, but it strikes me odd that it would run for 90 miles in 23 degrees or so and the operating temp never really fluctuates at all. and WA3PNT I probably allready have I'm always in scottsdale vending selling luchesse boots.
 

·
Registered
Joined
·
5,130 Posts
You aren't crazy. Its the truck. I have The Fix pending, keep your eyes peeled for my solution. I'll have a solution thread late February perhaps very early March with proof graphing so you KNOW the problem is gone.

GM won't be helping you. They are well aware of it.

So just hang tight a little bit longer, the LLY is soon to be the killer tow setup that is should have been from the start.

.

.
 
1 - 8 of 8 Posts
Top