Diesel Place banner

1 - 5 of 5 Posts

·
Registered
Joined
·
13 Posts
I have a 2005 GMC with LLY. Initially the truck shut off with no warning. Codes P1293, P2146, P2149, and P0201-0208. I sent the FICM in to be rebuilt. Reinstalled the repaired FICM. The truck started perfect, ran for 5 seconds and then back to the same thing. Exact same codes. I sent the FICM back again, it was repaired and reinstalled. The truck started up and ran fine for about 30 seconds and then the exact same thing again.


What would cause the FICM to continue to burn up. I have checked the harness and have not found any damage. It seems like the only way to burn up the FICM would be a voltage issue from the ECM or something similar. Any ideas? I need to get this truck back on the road since it is my work truck.


Thanks for the help.


Terry
 

·
Registered
Joined
·
13 Posts
Discussion Starter #3
I have searched the forums and have not found anything dealing specifically with my issues. I have replaced the entire wiring harness and FICM. I am still getting codes P0202,P0203,P0205,P0208, and P2149. I did get them to clear after the truck sat for a few days, the truck started and ran fine for about 30 seconds and then the codes listed above returned. I have been using another truck for work and need to get this one back running.
 

·
Registered
Joined
·
2,615 Posts
Heat in an electrical circuit is caused by electrical resistance, think like electric space heater. In auto circuits, that resistance is often caused by corrosion, rust, or poor connections.



You would be well served by purchasing a subscription to ALLDADIY.COM. There are tons of information and repair directions about your truck. Best cost benefit item you will find. It will tell you for a specific DTC code what conditions cause the DTC to set, how to test to see what is wrong, and what to do to fix the problem. Sounds like that would be very helpful in your case, especially you will fork out at least $125 to visit a dealer and ask a question.
 

·
Registered
2005 Silverado 2500hd ccsb LLY
Joined
·
2 Posts
I have searched the forums and have not found anything dealing specifically with my issues. I have replaced the entire wiring harness and FICM. I am still getting codes P0202,P0203,P0205,P0208, and P2149. I did get them to clear after the truck sat for a few days, the truck started and ran fine for about 30 seconds and then the codes listed above returned. I have been using another truck for work and need to get this one back running.
Did you ever find out your issue? I am currently hunting down the culprit on my 05 as well. Dont want to sink a ton of money into a new FICM and Harness if it is something else that is causing this issue.
Thanks!
 
1 - 5 of 5 Posts
Top