Diesel Place banner

1 - 12 of 12 Posts

·
Registered
Joined
·
1,283 Posts
Discussion Starter #1
I finally got my extreme and it did not come w/ any instructions to install the computer. I swapped it out only to find out that my truck did not start. After the first attempt I left the key in the run position for 15-20mins. to try and reset the security features. I tried it 2 more times but was unsuccessful. Any help?
 

·
Registered
Joined
·
12,262 Posts
Did you remove any fuses or are they all good? Did you put the switch pin in the proper location? Pin 69
 

·
Registered
Joined
·
1,283 Posts
Discussion Starter #3
i did not remove any fuses. I called Mike L. on his cell. He normally bails me out of situations like this. He mentioned removing a fuse but I could not find the fuse he was talking about.
The pins are set right. After I was unsuccessful w/ the extreme computer I put the stock one back in and it fired right up.
 

·
Registered
Joined
·
7,187 Posts
I finally got my extreme and it did not come w/ any instructions to install the computer. I swapped it out only to find out that my truck did not start. After the first attempt I left the key in the run position for 15-20mins. to try and reset the security features. I tried it 2 more times but was unsuccessful. Any help?
You can try to bump the key and then do not allow the truck to start, shut it off for a few minutes and try again.

When I installed mine it started up and then stalled, I had knocked a fuse loose in the fuse box because I installed new gauges at the same time and the IGN fuse was loose.

Once I got the fuse fixed it started up fine.

The green wire with the Switch goes to ECM connector BLUE- Pin #69, make sure it is fully seated, You need to carefully remove the grey outer connector of the ECM plug and then when you look at the part that goes to the ECM side the Blue plastic retaining clip gets removed to install the new wire.The ring goes to vehicle ground.

I would try the stock ECM at this point and if it does not start then you have a truck issue.

T;) NY
 

·
Registered
Joined
·
1,283 Posts
Discussion Starter #5
I called TTS mon. morning and it took Vicky less than 5 mins. to email the instructions. No-biggie. Also, Steve gave me a call around noon or so eastern time to make sure I had it. Thanks for the help guys. I will install shortly...
oops I cannot believe I posted in the wrong section. Sorry Mods.
 

·
Registered
Joined
·
3,049 Posts
I'm not positive but I think even without the pin installed into position 69 the TTS ecm will just default to the 80 hp setting, so unless you pinned it into the wrong hole and that is causing you a problem it is probablly just getting the ECM to learn your security code.

Good Luck.

By the way mine fired right up :)

And welcome to the club
 

·
Registered
Joined
·
609 Posts
I finally got my extreme and it did not come w/ any instructions to install the computer. I swapped it out only to find out that my truck did not start. After the first attempt I left the key in the run position for 15-20mins. to try and reset the security features. I tried it 2 more times but was unsuccessful. Any help?
+


Maybe the computer they sent to you is defective, I read somewhere that they use, used computers, you may want to call them, could be easy as having them send you another one.....
 

·
Registered
Joined
·
1,283 Posts
Discussion Starter #8
I am sure the computer is fine. I got off work late last night so I was unable to install it. Tonight I will make time.
 

·
Registered
Joined
·
3,652 Posts
Get it in yet?
 

·
Registered
Joined
·
214 Posts
Same thing happend to me. It turns out that you have to follow the 30 min. relearn process and then she'll fire. It was a little scary when she didnt fire the first time.
 

·
Registered
Joined
·
1,283 Posts
Discussion Starter #11
geese! what a difference. I love this thing. The only thing defective is my traction. It scares people when you chirp second w/ 35" tires.
 
1 - 12 of 12 Posts
Top